Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » button event delay
button event delay [message #449346] Sat, 22 January 2005 19:51 Go to next message
Eclipse UserFriend
Originally posted by: ryusasai.hotmail.com

Hi,

I wrote a java application with SWT using eclipse.
After launching, within first 10 hitting of buttons, one of them is really
slow, sometimes you have to 7 or 8 seconds for the event to come to the
button event handler.
After this one delay, the buttons are really responsive and delay never
happens, until you launch the application again.

Anyone having a good guess about this?

Thank you.

Ryu
Re: button event delay [message #449495 is a reply to message #449346] Tue, 25 January 2005 14:17 Go to previous message
Grant Gayed is currently offline Grant GayedFriend
Messages: 2150
Registered: July 2009
Senior Member
That sounds very strange. Are you able to provide a simple snippet that
shows the problem happening for you?

http://dev.eclipse.org/viewcvs/index.cgi/%7Echeckout%7E/plat form-swt-home/faq.html#whatisasnippet

Grant

"Ryu" <ryusasai@hotmail.com> wrote in message
news:csuase$51m$1@www.eclipse.org...
> Hi,
>
> I wrote a java application with SWT using eclipse.
> After launching, within first 10 hitting of buttons, one of them is really
> slow, sometimes you have to 7 or 8 seconds for the event to come to the
> button event handler.
> After this one delay, the buttons are really responsive and delay never
> happens, until you launch the application again.
>
> Anyone having a good guess about this?
>
> Thank you.
>
> Ryu
>
>
Previous Topic:Images in Tables (SWT.Check)
Next Topic:File creation
Goto Forum:
  


Current Time: Tue Nov 12 05:42:57 GMT 2019

Powered by FUDForum. Page generated in 0.02343 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top