Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » DirectoryFieldEditorQuestion
DirectoryFieldEditorQuestion [message #446130] Wed, 17 November 2004 16:10 Go to next message
Mark Victory is currently offline Mark VictoryFriend
Messages: 133
Registered: July 2009
Senior Member
Hi,

I have a DirectoryFieldEditor that is behaving badly.

If the user opens the preference page containing the DirectoryFieldEditor
then clicks the OK button without changing the value in the field then the
value for the field is deleted in the preferences store. I have an
IntegerFieldEditor and a ColorFieldEditor on the same page and these do not
exhibit this bad behavior.

Obviously, if the user does not change the setting in the
DirectoryFieldEditor then clicking OK should have no effect on the value.

Any ideas?

Thanks,
Mark
Re: DirectoryFieldEditorQuestion [message #446132 is a reply to message #446130] Wed, 17 November 2004 16:22 Go to previous messageGo to next message
Veronika Irvine is currently offline Veronika IrvineFriend
Messages: 1272
Registered: July 2009
Senior Member
Enter a bug report against Platform UI. Include a code example.

"Mark Victory" <MVictory@us.ibm.com> wrote in message
news:cnfsvd$vr8$1@www.eclipse.org...
> Hi,
>
> I have a DirectoryFieldEditor that is behaving badly.
>
> If the user opens the preference page containing the DirectoryFieldEditor
> then clicks the OK button without changing the value in the field then the
> value for the field is deleted in the preferences store. I have an
> IntegerFieldEditor and a ColorFieldEditor on the same page and these do
> not
> exhibit this bad behavior.
>
> Obviously, if the user does not change the setting in the
> DirectoryFieldEditor then clicking OK should have no effect on the value.
>
> Any ideas?
>
> Thanks,
> Mark
>
>
Re: DirectoryFieldEditorQuestion [message #446133 is a reply to message #446132] Wed, 17 November 2004 16:34 Go to previous message
Mark Victory is currently offline Mark VictoryFriend
Messages: 133
Registered: July 2009
Senior Member
Thanks Veronika,

I figured it out.
It was my problem.
I was setting the default value to be the "current value" when my
application started.
At storage time, when the default == current, the value is cleared in the
preferences store - which makes sense.

Thanks again,
Mark



"Veronika Irvine" <veronika_irvine@oti.com> wrote in message
news:cnftsi$2g7$1@www.eclipse.org...
> Enter a bug report against Platform UI. Include a code example.
>
> "Mark Victory" <MVictory@us.ibm.com> wrote in message
> news:cnfsvd$vr8$1@www.eclipse.org...
> > Hi,
> >
> > I have a DirectoryFieldEditor that is behaving badly.
> >
> > If the user opens the preference page containing the
DirectoryFieldEditor
> > then clicks the OK button without changing the value in the field then
the
> > value for the field is deleted in the preferences store. I have an
> > IntegerFieldEditor and a ColorFieldEditor on the same page and these do
> > not
> > exhibit this bad behavior.
> >
> > Obviously, if the user does not change the setting in the
> > DirectoryFieldEditor then clicking OK should have no effect on the
value.
> >
> > Any ideas?
> >
> > Thanks,
> > Mark
> >
> >
>
>
Previous Topic:Copy a table to clipboard
Next Topic:Can I get mouse position inside widget
Goto Forum:
  


Current Time: Sun Oct 25 09:04:30 GMT 2020

Powered by FUDForum. Page generated in 0.02033 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top