Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » swt-win32-3062.dll not found
swt-win32-3062.dll not found [message #444483] Thu, 14 October 2004 08:53
Eclipse UserFriend
Originally posted by: zzk101.163.net

Guys:
It's annoying to run/debug(in the eclipse) one swt program with the error
"swt-win32-3062.dll not found".

I
added -Djava.library.path=D:\eclipse3.0\plugins\org.eclipse.swt.wi n32_3.0.0\
os\win32\x86\swt-win32-3062.dll in the run wizard setting, but it didn't
work.

I have to copy this file to the run directory in order to run the program.
It's not good cause i run more than one program and i have to copy more than
one times.

Can you give me any advice? And why the first way doesn't work?

Best Regards
Vic
Re: swt-win32-3062.dll not found [message #444489 is a reply to message #444483] Wed, 13 October 2004 18:47 Go to previous message
Veronika Irvine is currently offline Veronika IrvineFriend
Messages: 1272
Registered: July 2009
Senior Member
java.library.path should point to the folder and not the dll itself. You
should use:

-Djava.library.path=D:\eclipse3.0\plugins\org.eclipse.swt.wi n32_3.0.0\os\win32\x86

See also:
http://dev.eclipse.org/viewcvs/index.cgi/%7Echeckout%7E/plat form-swt-home/faq.html#missingdll

> It's annoying to run/debug(in the eclipse) one swt program

Agreed. We are working on that. For now though, I put
the -Djava.library.path setting in the Default VM Arguments field. This way
I only have to set it once and can running any SWT application from then on
without worrying about it.

Window -> Preferences
Select Java -> Installed JREs
Select the VM
Click on Edit and put -Djava.library.path value in Default VM Arguments
field

"vic" <zzk101@163.net> wrote in message news:ckjpmv$6eb$1@eclipse.org...
> Guys:
> It's annoying to run/debug(in the eclipse) one swt program with the error
> "swt-win32-3062.dll not found".
>
> I
> added -Djava.library.path=D:\eclipse3.0\plugins\org.eclipse.swt.wi n32_3.0.0\
> os\win32\x86\swt-win32-3062.dll in the run wizard setting, but it didn't
> work.
>
> I have to copy this file to the run directory in order to run the
> program.
> It's not good cause i run more than one program and i have to copy more
> than
> one times.
>
> Can you give me any advice? And why the first way doesn't work?
>
> Best Regards
> Vic
>
>
Previous Topic:How to get Y-Location of a TreeItem
Next Topic:How to set the minimum size to a scrolled composite??
Goto Forum:
  


Current Time: Fri Oct 30 14:24:14 GMT 2020

Powered by FUDForum. Page generated in 0.01827 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top