Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Missing Plugin version while updating ?
Missing Plugin version while updating ? [message #43846] Mon, 02 February 2009 18:45 Go to next message
Martin Schmitz is currently offline Martin SchmitzFriend
Messages: 23
Registered: July 2009
Junior Member
Hello,

after a lot testing I built my base application with p2. Now I would
like to install my features with an update-site. One feature is for
running reports via BIRT. When trying to install this feature I get the
following error, but I really don't know whats missing.

org.eclipse.birt.data.aggregation is included in version 2.3.1

Any help is appreciated.

Thanks for helping
Martin


Cannot complete the request. See the details.
Unsatisfied dependency:
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/ [1.0.0,2.0.0)
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/ ]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/ ]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/ ]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/ ]
can be satisfied.
Unsatisfied dependency: [de.ling.arch.reporting.feature.group 5.0.15]
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/ [1.0.0,2.0.0)
Re: Missing Plugin version while updating ? [message #43909 is a reply to message #43846] Mon, 02 February 2009 21:28 Go to previous message
Eclipse UserFriend
Originally posted by: eclipse-news.rizzoweb.com

On 2/2/2009 1:45 PM, Martin Schmitz wrote:
> Hello,
>
> after a lot testing I built my base application with p2. Now I would
> like to install my features with an update-site. One feature is for
> running reports via BIRT. When trying to install this feature I get the
> following error, but I really don't know whats missing.
>
> org.eclipse.birt.data.aggregation is included in version 2.3.1

The messages below are telling you that something is limiting the
version of org.eclipse.birt.data.aggregation to between versions 1.0.0
and 2.0.0. That conflicts with requiring version 2.3.1 (which is larger
than 2.0.0).
I don't know if it is something in what you are trying to install, or
something that is already installed into the Eclipse that you are using,
that is not allowing above 2.0.0 - have fun trying to figure that out.

Hope this helps,
Eric


> Cannot complete the request. See the details.
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/ [1.0.0,2.0.0)
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/ ]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/ ]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/ ]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/ ]
> can be satisfied.
> Unsatisfied dependency: [de.ling.arch.reporting.feature.group 5.0.15]
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/ [1.0.0,2.0.0)
Re: Missing Plugin version while updating ? [message #591058 is a reply to message #43846] Mon, 02 February 2009 21:28 Go to previous message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
On 2/2/2009 1:45 PM, Martin Schmitz wrote:
> Hello,
>
> after a lot testing I built my base application with p2. Now I would
> like to install my features with an update-site. One feature is for
> running reports via BIRT. When trying to install this feature I get the
> following error, but I really don't know whats missing.
>
> org.eclipse.birt.data.aggregation is included in version 2.3.1

The messages below are telling you that something is limiting the
version of org.eclipse.birt.data.aggregation to between versions 1.0.0
and 2.0.0. That conflicts with requiring version 2.3.1 (which is larger
than 2.0.0).
I don't know if it is something in what you are trying to install, or
something that is already installed into the Eclipse that you are using,
that is not allowing above 2.0.0 - have fun trying to figure that out.

Hope this helps,
Eric


> Cannot complete the request. See the details.
> Unsatisfied dependency:
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/ [1.0.0,2.0.0)
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/ ]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/ ]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/ ]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/ ]
> can be satisfied.
> Unsatisfied dependency: [de.ling.arch.reporting.feature.group 5.0.15]
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.birt.data.aggregation/ [1.0.0,2.0.0)
Previous Topic:Missing Plugin version while updating ?
Next Topic:View source for plugins not in target platform
Goto Forum:
  


Current Time: Tue Jun 15 08:04:34 GMT 2021

Powered by FUDForum. Page generated in 0.01688 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top