Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » Teneo Hibernate Dialect must be explicitly set
Teneo Hibernate Dialect must be explicitly set [message #422691] Fri, 12 September 2008 22:31 Go to next message
Geoffry Roberts is currently offline Geoffry RobertsFriend
Messages: 71
Registered: July 2009
Member
All,

Its my first attempt with teneo and I'm getting an error: "Hibernate
Dialect must be explicitly set".

The dialect is being set in hibernate.properties and the file must be
being read because it also contains things like url, username , etc all of
which are working.

My EMF is trivial and is generated from an xsd. I doubt it is the problem
but I've included it below for good measure. IMHO the
hibernate.properties is also correct.

Any observations?

hibernate.properties:

hibernate.dialect org.hibernate.dialect.MySQLInnoDBDialect
hibernate.connection.driver_class com.mysql.jdbc.Driver
hibernate.connection.url jdbc:mysql://localhost:3306/epicase
hibernate.connection.username epiuser
hibernate.connection.password

xsd file:

<?xml version="1.0" encoding="UTF-8"?>
<!-- edited with XMLSpy v2006 rel. 3 sp2 (http://www.altova.com) by Gena
Samanc (Apogen Technologies) -->
<xs:schema xmlns="qq.mob.epicase.xsd"
xmlns:xs="http://www.w3.org/2001/XMLSchema"
xmlns:loc="qq.mob.location.xsd"
xmlns:ecore="http://www.eclipse.org/emf/2002/Ecore"
targetNamespace="qq.mob.epicase.xsd" elementFormDefault="qualified"
attributeFormDefault="unqualified">
<xs:complexType name="EpiCase">
<xs:sequence>
<xs:element name="zcta" type="xs:string"/>
<xs:element name="disease" type="xs:string"/>
<xs:element name="stage" type="xs:string"/>
</xs:sequence>
</xs:complexType>
</xs:schema>
Re: Teneo Hibernate Dialect must be explicitly set [message #422694 is a reply to message #422691] Sat, 13 September 2008 19:06 Go to previous messageGo to next message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Geoffry,
Which version of Teneo are you using? A few weeks back I solved an issue that hibernate.properties
were not used by hibernate.

Can you check if the hibernate.properties file is indeed copied to the output folder? It should be
present in the build.properties of the plugin.

gr. Martin

Geoffry Roberts wrote:
> All,
>
> Its my first attempt with teneo and I'm getting an error: "Hibernate
> Dialect must be explicitly set".
>
> The dialect is being set in hibernate.properties and the file must be
> being read because it also contains things like url, username , etc all
> of which are working.
>
> My EMF is trivial and is generated from an xsd. I doubt it is the
> problem but I've included it below for good measure. IMHO the
> hibernate.properties is also correct.
>
> Any observations?
>
> hibernate.properties:
>
> hibernate.dialect org.hibernate.dialect.MySQLInnoDBDialect
> hibernate.connection.driver_class com.mysql.jdbc.Driver
> hibernate.connection.url jdbc:mysql://localhost:3306/epicase
> hibernate.connection.username epiuser
> hibernate.connection.password
>
> xsd file:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <!-- edited with XMLSpy v2006 rel. 3 sp2 (http://www.altova.com) by Gena
> Samanc (Apogen Technologies) -->
> <xs:schema xmlns="qq.mob.epicase.xsd"
> xmlns:xs="http://www.w3.org/2001/XMLSchema"
> xmlns:loc="qq.mob.location.xsd"
> xmlns:ecore="http://www.eclipse.org/emf/2002/Ecore"
> targetNamespace="qq.mob.epicase.xsd" elementFormDefault="qualified"
> attributeFormDefault="unqualified">
> <xs:complexType name="EpiCase">
> <xs:sequence>
> <xs:element name="zcta" type="xs:string"/>
> <xs:element name="disease" type="xs:string"/>
> <xs:element name="stage" type="xs:string"/>
> </xs:sequence>
> </xs:complexType>
> </xs:schema>
>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Cell: +31 (0)6 288 48 943
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: Teneo Hibernate Dialect must be explicitly set [message #422735 is a reply to message #422694] Mon, 15 September 2008 16:10 Go to previous messageGo to next message
Geoffry Roberts is currently offline Geoffry RobertsFriend
Messages: 71
Registered: July 2009
Member
Martin Taal wrote:

> Hi Geoffry,
> Which version of Teneo are you using? A few weeks back I solved an issue

My About eclipse plug ins listing shows the version to be:
1.1.v200806091234
It is what was in the ganymede distribution.

that hibernate.properties
> were not used by hibernate.

> Can you check if the hibernate.properties file is indeed copied to the
output folder? It should be

Yes, hibernate.properties is indeed in the output folder.

Just so you'll know, I use Hibernate extensively sans teneo. It is only
when I try the EMF/teneo that I encounter this problem. As I stated
before, hibernate.properties is being read, by hibernate. It would appear
that it's only when teneo gets involved that things go wrong.

> present in the build.properties of the plugin.

> gr. Martin

> Geoffry Roberts wrote:
>> All,
>>
>> Its my first attempt with teneo and I'm getting an error: "Hibernate
>> Dialect must be explicitly set".
>>
>> The dialect is being set in hibernate.properties and the file must be
>> being read because it also contains things like url, username , etc all
>> of which are working.
>>
>> My EMF is trivial and is generated from an xsd. I doubt it is the
>> problem but I've included it below for good measure. IMHO the
>> hibernate.properties is also correct.
>>
>> Any observations?
>>
>> hibernate.properties:
>>
>> hibernate.dialect org.hibernate.dialect.MySQLInnoDBDialect
>> hibernate.connection.driver_class com.mysql.jdbc.Driver
>> hibernate.connection.url jdbc:mysql://localhost:3306/epicase
>> hibernate.connection.username epiuser
>> hibernate.connection.password
>>
>> xsd file:
>>
>> <?xml version="1.0" encoding="UTF-8"?>
>> <!-- edited with XMLSpy v2006 rel. 3 sp2 (http://www.altova.com) by Gena
>> Samanc (Apogen Technologies) -->
>> <xs:schema xmlns="qq.mob.epicase.xsd"
>> xmlns:xs="http://www.w3.org/2001/XMLSchema"
>> xmlns:loc="qq.mob.location.xsd"
>> xmlns:ecore="http://www.eclipse.org/emf/2002/Ecore"
>> targetNamespace="qq.mob.epicase.xsd" elementFormDefault="qualified"
>> attributeFormDefault="unqualified">
>> <xs:complexType name="EpiCase">
>> <xs:sequence>
>> <xs:element name="zcta" type="xs:string"/>
>> <xs:element name="disease" type="xs:string"/>
>> <xs:element name="stage" type="xs:string"/>
>> </xs:sequence>
>> </xs:complexType>
>> </xs:schema>
>>
Re: Teneo Hibernate Dialect must be explicitly set [message #422736 is a reply to message #422735] Mon, 15 September 2008 16:19 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Geoffry,
Yes this was an issue I solved a few weeks back. When you update to the latest 1.0.1 M build of
Teneo then this should be solved.

gr. Martin

Geoffry Roberts wrote:
> Martin Taal wrote:
>
>> Hi Geoffry,
>> Which version of Teneo are you using? A few weeks back I solved an issue
>
> My About eclipse plug ins listing shows the version to be:
> 1.1.v200806091234
> It is what was in the ganymede distribution.
>
> that hibernate.properties
>> were not used by hibernate.
>
>> Can you check if the hibernate.properties file is indeed copied to the
> output folder? It should be
> Yes, hibernate.properties is indeed in the output folder.
>
> Just so you'll know, I use Hibernate extensively sans teneo. It is only
> when I try the EMF/teneo that I encounter this problem. As I stated
> before, hibernate.properties is being read, by hibernate. It would
> appear that it's only when teneo gets involved that things go wrong.
>
>> present in the build.properties of the plugin.
>
>> gr. Martin
>
>> Geoffry Roberts wrote:
>>> All,
>>>
>>> Its my first attempt with teneo and I'm getting an error: "Hibernate
>>> Dialect must be explicitly set".
>>>
>>> The dialect is being set in hibernate.properties and the file must be
>>> being read because it also contains things like url, username , etc
>>> all of which are working.
>>>
>>> My EMF is trivial and is generated from an xsd. I doubt it is the
>>> problem but I've included it below for good measure. IMHO the
>>> hibernate.properties is also correct.
>>>
>>> Any observations?
>>>
>>> hibernate.properties:
>>>
>>> hibernate.dialect org.hibernate.dialect.MySQLInnoDBDialect
>>> hibernate.connection.driver_class com.mysql.jdbc.Driver
>>> hibernate.connection.url jdbc:mysql://localhost:3306/epicase
>>> hibernate.connection.username epiuser
>>> hibernate.connection.password
>>>
>>> xsd file:
>>>
>>> <?xml version="1.0" encoding="UTF-8"?>
>>> <!-- edited with XMLSpy v2006 rel. 3 sp2 (http://www.altova.com) by
>>> Gena Samanc (Apogen Technologies) -->
>>> <xs:schema xmlns="qq.mob.epicase.xsd"
>>> xmlns:xs="http://www.w3.org/2001/XMLSchema"
>>> xmlns:loc="qq.mob.location.xsd"
>>> xmlns:ecore="http://www.eclipse.org/emf/2002/Ecore"
>>> targetNamespace="qq.mob.epicase.xsd" elementFormDefault="qualified"
>>> attributeFormDefault="unqualified">
>>> <xs:complexType name="EpiCase">
>>> <xs:sequence>
>>> <xs:element name="zcta" type="xs:string"/>
>>> <xs:element name="disease" type="xs:string"/>
>>> <xs:element name="stage" type="xs:string"/>
>>> </xs:sequence>
>>> </xs:complexType>
>>> </xs:schema>
>>>
>
>
>
>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Cell: +31 (0)6 288 48 943
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Previous Topic:[CDO]: CDO Resource Launcher
Next Topic:[Teneo] Latest milestone does not show in list of plugins
Goto Forum:
  


Current Time: Thu Sep 24 13:02:02 GMT 2020

Powered by FUDForum. Page generated in 0.02042 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top