Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Looking for API to add an extension entry in plugin.xml.
Looking for API to add an extension entry in plugin.xml. [message #39189] Tue, 06 January 2009 05:00 Go to next message
Mark Espiritu is currently offline Mark EspirituFriend
Messages: 9
Registered: July 2009
Junior Member
Hi all,

I'm writing a wizard that will create new PDE projects. What I'm trying
to do now is programatically add extension entries to plugin.xml.

Can you please point me to the direction of the model APIs and how to
use them? Are the sample codes I can study?

I'm hoping there's a better way then string manipulation, which is what
I currently plan to do.

Help will be appreciated. Thanks!

Regards,
Mark
Re: Looking for API to add an extension entry in plugin.xml. [message #39222 is a reply to message #39189] Tue, 06 January 2009 07:02 Go to previous messageGo to next message
Prakash G.R. is currently offline Prakash G.R.Friend
Messages: 621
Registered: July 2009
Senior Member
You can look into the PDE's template extension point (o.e.pde.ui.templates)
and the extensions implementing it (in the o.e.pde.ui.templates plugin)

- Prakash

--

http://blog.eclipse-tips.com

"Mark Espiritu" <mark.espiritu@vastsystems.com.au> wrote in message
news:gjuol0$8qn$1@build.eclipse.org...
> Hi all,
>
> I'm writing a wizard that will create new PDE projects. What I'm trying to
> do now is programatically add extension entries to plugin.xml.
>
> Can you please point me to the direction of the model APIs and how to use
> them? Are the sample codes I can study?
>
> I'm hoping there's a better way then string manipulation, which is what I
> currently plan to do.
>
> Help will be appreciated. Thanks!
>
> Regards,
> Mark
Re: Looking for API to add an extension entry in plugin.xml. [message #39376 is a reply to message #39222] Thu, 08 January 2009 06:03 Go to previous message
Mark Espiritu is currently offline Mark EspirituFriend
Messages: 9
Registered: July 2009
Junior Member
Hi Prakash,

Thanks for the suggestion.

I can't quite get it to work. Existing extensions are losing child
elements wherever I add a new extension entry to the model. I must be
doing something wrong.

Also, I seem to be been using PDE internal classes which worries me a
bit. So, I'm thinking of dropping this approach. Unless there are public
classes you can refer me to?

Otherwise, thanks anyway for the help.

Regards,
Mark


Prakash G.R. wrote:
> You can look into the PDE's template extension point
> (o.e.pde.ui.templates) and the extensions implementing it (in the
> o.e.pde.ui.templates plugin)
>
> - Prakash
>
Re: Looking for API to add an extension entry in plugin.xml. [message #587836 is a reply to message #39189] Tue, 06 January 2009 07:02 Go to previous message
Prakash G.R. is currently offline Prakash G.R.Friend
Messages: 621
Registered: July 2009
Senior Member
You can look into the PDE's template extension point (o.e.pde.ui.templates)
and the extensions implementing it (in the o.e.pde.ui.templates plugin)

- Prakash

--

http://blog.eclipse-tips.com

"Mark Espiritu" <mark.espiritu@vastsystems.com.au> wrote in message
news:gjuol0$8qn$1@build.eclipse.org...
> Hi all,
>
> I'm writing a wizard that will create new PDE projects. What I'm trying to
> do now is programatically add extension entries to plugin.xml.
>
> Can you please point me to the direction of the model APIs and how to use
> them? Are the sample codes I can study?
>
> I'm hoping there's a better way then string manipulation, which is what I
> currently plan to do.
>
> Help will be appreciated. Thanks!
>
> Regards,
> Mark
Re: Looking for API to add an extension entry in plugin.xml. [message #587878 is a reply to message #39222] Thu, 08 January 2009 06:03 Go to previous message
Mark Espiritu is currently offline Mark EspirituFriend
Messages: 9
Registered: July 2009
Junior Member
Hi Prakash,

Thanks for the suggestion.

I can't quite get it to work. Existing extensions are losing child
elements wherever I add a new extension entry to the model. I must be
doing something wrong.

Also, I seem to be been using PDE internal classes which worries me a
bit. So, I'm thinking of dropping this approach. Unless there are public
classes you can refer me to?

Otherwise, thanks anyway for the help.

Regards,
Mark


Prakash G.R. wrote:
> You can look into the PDE's template extension point
> (o.e.pde.ui.templates) and the extensions implementing it (in the
> o.e.pde.ui.templates plugin)
>
> - Prakash
>
Previous Topic:running Project -> Clean.. causes BundleException error
Next Topic:How to exclude some plugins from a headless build?
Goto Forum:
  


Current Time: Fri Jun 18 19:10:54 GMT 2021

Powered by FUDForum. Page generated in 0.02383 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top