Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Plug-In Development
Plug-In Development [message #35171] Tue, 02 December 2008 14:41 Go to next message
Luke is currently offline LukeFriend
Messages: 14
Registered: July 2009
Junior Member
I am returning to Eclipse after a period of having been away from using
it. I am tasked to do some Plugin and RCP development. I downloaded the
Java Development version, but see it is missing Plugin development.

So here I sit confused. You use to be able to just add that stuff on via
the "updater", but I can't figure out how/where.

If I am going to be doing Equinox, RCP, Plugin development either: what
distro do I need to get, or how do I add on what I need to the Java
development distro I have? Do you get the various distros and just overlay
them??

This has really gotten confusing.

Thanks for your help.
Re: Plug-In Development [message #35195 is a reply to message #35171] Tue, 02 December 2008 15:23 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mihael.rpgnextgen.com

On the eclipse.org site go to the menu downloads. There is a package
"Eclipse for RCP/Plugin Developers". That should have all you need.

Am Dienstag, den 02.12.2008, 14:41 +0000 schrieb Luke :
> I am returning to Eclipse after a period of having been away from using
> it. I am tasked to do some Plugin and RCP development. I downloaded the
> Java Development version, but see it is missing Plugin development.
>
> So here I sit confused. You use to be able to just add that stuff on via
> the "updater", but I can't figure out how/where.
>
> If I am going to be doing Equinox, RCP, Plugin development either: what
> distro do I need to get, or how do I add on what I need to the Java
> development distro I have? Do you get the various distros and just overlay
> them??
>
> This has really gotten confusing.
>
> Thanks for your help.
>
Re: Plug-In Development [message #35272 is a reply to message #35171] Tue, 02 December 2008 18:49 Go to previous message
Eclipse UserFriend
Originally posted by: eclipse-news.rizzoweb.com

On 12/2/2008 9:41 AM, Luke wrote:
> I am returning to Eclipse after a period of having been away from using
> it. I am tasked to do some Plugin and RCP development. I downloaded the
> Java Development version, but see it is missing Plugin development.
>
> So here I sit confused. You use to be able to just add that stuff on via
> the "updater", but I can't figure out how/where.
>
> If I am going to be doing Equinox, RCP, Plugin development either: what
> distro do I need to get, or how do I add on what I need to the Java
> development distro I have? Do you get the various distros and just
> overlay them??

Help > Software Updates..., then select the Available Software tab.
You'll want to find the category "Eclipse Project Updates" and under
that select the Platform SDK and anything under Uncategorized that looks
relevant (anything with RCP, plug-in, PDE, etc. in the name).

But like Mihael said, it is simplest to just download the RCP/Plug-in
Developer package.

Hope this helps,
Eric
Re: Plug-In Development [message #586164 is a reply to message #35171] Tue, 02 December 2008 15:23 Go to previous message
Mihael Schmidt is currently offline Mihael SchmidtFriend
Messages: 81
Registered: August 2010
Member
On the eclipse.org site go to the menu downloads. There is a package
"Eclipse for RCP/Plugin Developers". That should have all you need.

Am Dienstag, den 02.12.2008, 14:41 +0000 schrieb Luke :
> I am returning to Eclipse after a period of having been away from using
> it. I am tasked to do some Plugin and RCP development. I downloaded the
> Java Development version, but see it is missing Plugin development.
>
> So here I sit confused. You use to be able to just add that stuff on via
> the "updater", but I can't figure out how/where.
>
> If I am going to be doing Equinox, RCP, Plugin development either: what
> distro do I need to get, or how do I add on what I need to the Java
> development distro I have? Do you get the various distros and just overlay
> them??
>
> This has really gotten confusing.
>
> Thanks for your help.
>
Re: Plug-In Development [message #586192 is a reply to message #35171] Tue, 02 December 2008 18:49 Go to previous message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
On 12/2/2008 9:41 AM, Luke wrote:
> I am returning to Eclipse after a period of having been away from using
> it. I am tasked to do some Plugin and RCP development. I downloaded the
> Java Development version, but see it is missing Plugin development.
>
> So here I sit confused. You use to be able to just add that stuff on via
> the "updater", but I can't figure out how/where.
>
> If I am going to be doing Equinox, RCP, Plugin development either: what
> distro do I need to get, or how do I add on what I need to the Java
> development distro I have? Do you get the various distros and just
> overlay them??

Help > Software Updates..., then select the Available Software tab.
You'll want to find the category "Eclipse Project Updates" and under
that select the Platform SDK and anything under Uncategorized that looks
relevant (anything with RCP, plug-in, PDE, etc. in the name).

But like Mihael said, it is simplest to just download the RCP/Plug-in
Developer package.

Hope this helps,
Eric
Previous Topic:editor display on menu
Next Topic:Multiple bundles with the same version
Goto Forum:
  


Current Time: Thu Aug 05 21:32:31 GMT 2021

Powered by FUDForum. Page generated in 0.01690 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top