Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Problems with p2-izing a product
Problems with p2-izing a product [message #34556] Tue, 25 November 2008 19:26
Ketan Padegaonkar is currently offline Ketan PadegaonkarFriend
Messages: 873
Registered: July 2009
Senior Member
Hi,

I'm unable to p2-ize a product, after about a week of "monkey see,
monkey do", and I'm convinced that there's something wrong in what I'm
doing.

I'm p2-izing my product using the following command line:

<java
classpath=" ${p2.eclipse.dir}/plugins/org.eclipse.equinox.launcher_${ecl ipse.launcher.version}.jar "
classname="org.eclipse.equinox.launcher.Main" timeout="30000000"
resultproperty="p2.build.exit.code" fork="true">
<arg line="-clean -consoleLog -debug -nosplash -nosplash
--launcher.suppressErrors" />
<arg line="-application
org.eclipse.equinox.p2.director.app.application" />
<arg line="-flavor tooling" />
<arg line="-installIU ${p2.IU}" />
<!--arg line="-list" /-->
<arg line="-version ${p2.version}" />
<arg line="-p2.os ${p2.os}" />
<arg line="-p2.ws ${p2.ws}" />
<arg line="-p2.arch ${p2.arch}" />
<arg line="-roaming" />
<arg line="-profile TwistProfile" />
<arg line="-metadataRepository file:${build_directory}/repo/" />
<arg line="-artifactRepository file:${build_directory}/repo/" />
<arg line="-destination ${p2.director.install.path}" />
<arg line="-bundlepool ${p2.director.install.path}" />
<jvmarg line="-Declipse.p2.data.area=${p2.director.install.path}/p2 "/>
</java>

However the exec fails with a lot of errors:

[java] !SUBENTRY 1 org.eclipse.equinox.p2.core 2 0 2008-11-26
00:39:55.022
[java] !MESSAGE Error at line 10, column 91: Missing required
attribute in "repository": url
[java] !SUBENTRY 1 org.eclipse.equinox.p2.core 2 0 2008-11-26
00:39:55.023
[java] !MESSAGE Error at line 10, column 91: Illegal value for
attribute "url" of element "repository": null
[java] !SUBENTRY 1 org.eclipse.equinox.p2.core 2 0 2008-11-26
00:39:55.024
[java] !MESSAGE Error at line 11, column 91: Missing required
attribute in "repository": url
[java] !SUBENTRY 1 org.eclipse.equinox.p2.core 2 0 2008-11-26
00:39:55.026
[java] !MESSAGE Error at line 11, column 91: Illegal value for
attribute "url" of element "repository": null
[java] !SUBENTRY 1 org.eclipse.equinox.p2.core 2 0 2008-11-26
00:39:55.027
[java] !MESSAGE Error at line 12, column 90: Missing required
attribute in "repository": url
[java] !SUBENTRY 1 org.eclipse.equinox.p2.core 2 0 2008-11-26
00:39:55.029
[java] !MESSAGE Error at line 12, column 90: Illegal value for
attribute "url" of element "repository": null
[java] !SUBENTRY 1 org.eclipse.equinox.p2.core 2 0 2008-11-26
00:39:55.030
[java] !MESSAGE Error at line 13, column 90: Missing required
attribute in "repository": url
[java] !SUBENTRY 1 org.eclipse.equinox.p2.core 2 0 2008-11-26
00:39:55.032
[java] !MESSAGE Error at line 13, column 90: Illegal value for
attribute "url" of element "repository": null
[java]
[java] !ENTRY org.eclipse.equinox.p2.director.app 4 0 2008-11-26
00:41:43.818
[java] !MESSAGE The installable unit
com.thoughtworks.twist.eclipse.ui.product has not been found.
[java] The installable unit
com.thoughtworks.twist.eclipse.ui.product has not been found.
[java] Java Result: 13

The installation unit "com.thoughtworks.twist.eclipse.ui.product"
however does exist and is listed when I use the -list argument.

I'm also not sure why the other errors about illegal values crop up.

-- Ketan
Previous Topic:Creating a p2 based product is very slow.
Next Topic:Problems with p2-izing a product
Goto Forum:
  


Current Time: Sun Jul 25 07:38:59 GMT 2021

Powered by FUDForum. Page generated in 0.02076 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top