Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Problems(Multiple problems using Eclipse)
Problems [message #1857021] Fri, 13 January 2023 08:41 Go to next message
Carl Emmoth is currently offline Carl EmmothFriend
Messages: 1
Registered: January 2023
Junior Member
Hello,

I've been using Eclipse for more than 10 years. I write here because I would consider myslefs a "newcomer" with the new versions and using Open API, Typescript etc with Eclipse.

I love Eclipse when coding Java. I'm addicted to the "Problems" tab. But in our latest setup at work, there were multiple problems. I just want to write them down and maybe there are solutions for them. In the end, it was impossible to use Eclipse professionally.

Problems:

- Maven project could trigger problems that was not solved

- Using multiple Open API specifications that referencing to common OpenAPI and using Maven plugin to build, triggers endless build. Possible multiple projects compiled shared classes which led to an change and the build restarted

- Typescript triggered "Language servers" and Eclipse went slower and slower. In the end the language servers was constantly loading

- Using Angular project with Prettyfier made all formatting issues as errors. And solving it Eclipse formatted one line at the time. This was impossible to use for large files

- It would be nice to have Lombok installed through Eclipse. I used Lombok's own installation

I was using an Eclipse 2022 version
Re: Problems [message #1857034 is a reply to message #1857021] Fri, 13 January 2023 16:37 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32663
Registered: July 2009
Senior Member
Unfortunately these problems span multiple technologies, maybe not even all hosted as Eclipse projects In any case, it's unlikely that any of the people providing these technologies will see your comment here.

For Maven problems you could report them on the issues list here:

https://github.com/eclipse-m2e/m2e-core

I highly recommend you find appropriate places to report the problems...


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Problems [message #1857037 is a reply to message #1857034] Fri, 13 January 2023 19:31 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4304
Registered: July 2009
Senior Member

TypeScript with language servers sounds like something to bring up at https://github.com/eclipse/wildwebdeveloper .

Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:Can't post message in PDE forum
Next Topic:Errors in Eclipse but not Netbeans exact same project
Goto Forum:
  


Current Time: Sat Feb 04 16:51:25 GMT 2023

Powered by FUDForum. Page generated in 2.16131 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top