Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse tar.gz does not want to decompress(Download tar result seems always corrupt in some ways)
Eclipse tar.gz does not want to decompress [message #1855660] Wed, 26 October 2022 02:21 Go to next message
Mark Boyher is currently offline Mark BoyherFriend
Messages: 1
Registered: October 2022
Junior Member
Inside of new install of Debian Linux OS using Firefox:

I am downloading the tar.gz file for Eclipse at the terminal line. Then I am performing the below.

terminal command:
tar -xvf clipse-cpp-2022-09-R-linux-gtk-x86_64.JxlV9KwX.tar.gz.part

also tried:
tar -tvf clipse-cpp-2022-09-R-linux-gtk-x86_64.JxlV9KwX.tar.gz.part
tar -tvf eclipse-cpp-2022-09-R-linux-gtk-x86_64.tar.gz
tar -xvf eclipse-cpp-2022-09-R-linux-gtk-x86_64.tar.gz

files after download:
-rw------- 1 cmboyher cmboyher 132783848 Oct 25 18:55 eclipse-cpp-2022-09-R-linux-gtk-x86_64.JxlV9KwX.tar.gz.part
-rw-r--r-- 1 cmboyher cmboyher 0 Oct 25 18:42 eclipse-cpp-2022-09-R-linux-gtk-x86_64.tar.gz

Why is the *tar.gz of 0 size?

No matter what I get:
gzip: stdin: unexpected end of file
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now

However, when decompressing eclipse-cpp-2022-09-R-linux-gtk-x86_64.JxlV9KwX.tar.gz.part results in the following.

I get what seems like a normal operation as shown in the attached file (result_for_tar_gz_part_file.txt) up until I ALSO get the same result at the end shown below. I do not know if it decompressed everything properly also.

gzip: stdin: unexpected end of file
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now

I assume this is something simple as I have tested tar with non-eclipse tar files and it seems to work, yet not with the Eclipse.

Re: Eclipse tar.gz does not want to decompress [message #1855662 is a reply to message #1855660] Wed, 26 October 2022 02:59 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4345
Registered: July 2009
Senior Member

A .part file is likely an incomplete or in-progress download, which is probably related to the file with the right name looking like it
has a length of zero. For a complete file, none of those are the right combination of arguments for a .tar.gz file: xvzf.

x = extract
v = verbose (you can leave this out)
z = uncompress using gzip before untarring
f = next argument is the file name to work on

So, e.g. "tar xvzf eclipse-cpp-2022-09-R-linux-gtk-x86_64.tar.gz".

Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:Books on Eclipse
Next Topic:Unable to create Eclipse RCP Application
Goto Forum:

Current Time: Wed Jun 07 05:58:49 GMT 2023

Powered by FUDForum. Page generated in 0.02639 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top