Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Plug-in org.eclipse.jdt.ui was unable to load (Unable to run or do anything in the eclipse)
Plug-in org.eclipse.jdt.ui was unable to load [message #1854832] Tue, 13 September 2022 19:09 Go to next message
Shwetha Kolekar is currently offline Shwetha KolekarFriend
Messages: 1
Registered: September 2022
Junior Member
I have tried to add JDK using build path and by mistake selected some other file,
and my eclipse started to give my lot of errors and not able to do anything,
see the attached pitcher and log file and let me know what should I do ?

  • Attachment: build path.PNG
    (Size: 42.09KB, Downloaded 16 times)
  • Attachment: log.log
    (Size: 545.95KB, Downloaded 14 times)
Re: Plug-in org.eclipse.jdt.ui was unable to load [message #1854833 is a reply to message #1854832] Tue, 13 September 2022 19:15 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4264
Registered: July 2009
Senior Member

I suggest you report an issue using the instructions at https://github.com/eclipse-jdt , specifically to JDT Core.

Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Tue, 13 September 2022 19:22]

Report message to a moderator

Re: Plug-in org.eclipse.jdt.ui was unable to load [message #1854844 is a reply to message #1854833] Wed, 14 September 2022 07:46 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32494
Registered: July 2009
Senior Member
The build path is stored in the .classpath file in the root of the project. You can use the view menu (the vertical ... in the package explorer view) for the Filters... and uncheck .*resources. Then you can probably fix the file (remove the "other thing") manually. You should still report an issue!

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Plug-in org.eclipse.jdt.ui was unable to load [message #1854847 is a reply to message #1854844] Wed, 14 September 2022 09:59 Go to previous messageGo to next message
cristelle AMELDA is currently offline cristelle AMELDAFriend
Messages: 6
Registered: August 2022
Junior Member
If not, what would that entail?
Re: Plug-in org.eclipse.jdt.ui was unable to load [message #1854848 is a reply to message #1854847] Wed, 14 September 2022 12:15 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 32494
Registered: July 2009
Senior Member
I overlooked the log. This workspace looks seriously hosed. I would start with a fresh new workspace and use File -> Import -> Existing Projects into Workspace and locate folder where your projects are located for the "Select root directory". Note the "Copy projects into workspace" checkbox; If you're used to having the projects physically nested in the workspace, you'll probably want to copy them from the old workspace to the new one.

But again, you should report an issue. The JDT development may have better insights looking at your stack traces...


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Error during publish jetty 10.0.11
Next Topic:Eclipse 2022-09 no "import existing maven project"
Goto Forum:
  


Current Time: Mon Sep 26 13:57:27 GMT 2022

Powered by FUDForum. Page generated in 0.03686 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top