Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Maven build
Maven build [message #1854786] Sat, 10 September 2022 08:25 Go to next message
jo ber is currently offline jo berFriend
Messages: 86
Registered: August 2018
Member
Hello

I've a dsl 'org.xtext.example.mydsla' that I want to use inside a standard maven application 'example-project'. During the build, the following error is raised:

Downloading from central: https://repo.maven.apache.org/maven2/org/osgi/org.osgi.util.measurement/1.0.2/org.osgi.util.measurement-1.0.2.eclipse-plugin
Downloading from central: https://repo.maven.apache.org/maven2/org/osgi/org.osgi.util.position/1.0.1/org.osgi.util.position-1.0.1.eclipse-plugin
Downloading from central: https://repo.maven.apache.org/maven2/org/osgi/org.osgi.util.promise/1.2.0/org.osgi.util.promise-1.2.0.eclipse-plugin
Downloading from central: https://repo.maven.apache.org/maven2/org/osgi/org.osgi.service.prefs/1.1.2/org.osgi.service.prefs-1.1.2.eclipse-plugin
Downloading from central: https://repo.maven.apache.org/maven2/org/osgi/org.osgi.util.function/1.2.0/org.osgi.util.function-1.2.0.eclipse-plugin
Downloading from central: https://repo.maven.apache.org/maven2/org/osgi/org.osgi.util.xml/1.0.2/org.osgi.util.xml-1.0.2.eclipse-plugin
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time:  0.854 s
[INFO] Finished at: 2022-09-10T10:22:22+02:00
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.eclipse.xtext:xtext-maven-plugin:2.27.0:generate (default) on project example-project: Execution default of goal org.eclipse.xtext:xtext-maven-plugin:2.27.0:generate failed: Plugin org.eclipse.xtext:xtext-maven-plugin:2.27.0 or one of its dependencies could not be resolved: The following artifacts could not be resolved: org.osgi:org.osgi.util.promise:eclipse-plugin:1.2.0, org.osgi:org.osgi.service.prefs:eclipse-plugin:1.1.2, org.osgi:org.osgi.util.function:eclipse-plugin:1.2.0, org.osgi:org.osgi.util.measurement:eclipse-plugin:1.0.2, org.osgi:org.osgi.util.position:eclipse-plugin:1.0.1, org.osgi:org.osgi.util.xml:eclipse-plugin:1.0.2: Could not find artifact org.osgi:org.osgi.util.promise:eclipse-plugin:1.2.0 in central (https://repo.maven.apache.org/maven2) -> [Help 1]


I'm using maven v 3.8.4
The downloads of the six dependencies at the bginning above looks strange to me...

Any help is welcome
kind regards,

Re: Maven build [message #1854787 is a reply to message #1854786] Sat, 10 September 2022 08:56 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 14349
Registered: July 2009
Senior Member
Sounds like <a href=""></a>https://github.com/eclipse-tycho/tycho/discussions/989
https://github.com/eclipse-tycho/tycho/issues/1043


https://github.com/xtext/maven-xtext-example/commit/d41a3649107e4089f8bb4f02c7fd0659be96b99b


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de

[Updated on: Sat, 10 September 2022 09:06]

Report message to a moderator

Re: Maven build [message #1854788 is a reply to message #1854787] Sat, 10 September 2022 09:05 Go to previous message
jo ber is currently offline jo berFriend
Messages: 86
Registered: August 2018
Member
yes, that was the problem, needed to add: https://github.com/xtext/maven-xtext-example/blob/d41a3649107e4089f8bb4f02c7fd0659be96b99b/pom.xml#L75

Thank you
Previous Topic:Write grammars for SQL and Cypher languages
Next Topic:Xtext & Xtend for Java 17: please help testing
Goto Forum:
  


Current Time: Mon Sep 26 13:52:12 GMT 2022

Powered by FUDForum. Page generated in 0.01546 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top