Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » I have 2 DSLs. When I launch the 2nd instance of Eclipse only 1 of them is active.(xtext project build configuration)
I have 2 DSLs. When I launch the 2nd instance of Eclipse only 1 of them is active. [message #1853505] Wed, 06 July 2022 04:42 Go to next message
Gary Worsham is currently offline Gary WorshamFriend
Messages: 14
Registered: June 2022
Junior Member
Hi again,

I'm still trying to pick up where I left off about 4 years ago.

So, as the title indicates, my project has 2 different DSLs but only one of them is getting launched when I run Eclipse. I don't know where to look for this info.

index.php/fa/42266/0/
index.php/fa/42268/0/

The language infrastructure builds without error in both cases.

index.php/fa/42269/0/
index.php/fa/42270/0/

Here are the properties in the new Eclipse. Notice that "SpinCAD" is missing.
index.php/fa/42271/0/


[Updated on: Wed, 06 July 2022 04:46]

Report message to a moderator

Re: I have 2 DSLs. When I launch the 2nd instance of Eclipse only 1 of them is active. [message #1853506 is a reply to message #1853505] Wed, 06 July 2022 04:45 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 14434
Registered: July 2009
Senior Member
can you check the launch configuration if you select all dsls, if it shows errors for dsls?
can you check the plugin.xml_gen / plugin.xml files if there first is properly merged to second
in the runtime eclipse can you check the host osgi console (+ button in console view) and type "ss spin" there
if your spin plugins are not active can you then type start <id of non active plugin>


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: I have 2 DSLs. When I launch the 2nd instance of Eclipse only 1 of them is active. [message #1853507 is a reply to message #1853506] Wed, 06 July 2022 05:07 Go to previous messageGo to next message
Gary Worsham is currently offline Gary WorshamFriend
Messages: 14
Registered: June 2022
Junior Member
Thanks for the response. I'm not entirely sure what you meant by some of your questions but I'll show you what I think you are asking for.

index.php/fa/42272/0/

index.php/fa/42273/0/

xml (one that's not working)

<?xml version="1.0" encoding="UTF-8"?>
<?eclipse version="3.0"?>

<plugin>

  <extension point="org.eclipse.emf.ecore.generated_package">
    <package 
       uri = "http://www.holycityaudio.com/spincad/SpinCAD" 
       class = "com.holycityaudio.spincad.spinCAD.SpinCADPackage"
       genModel = "model/generated/SpinCAD.genmodel" /> 
	
  </extension>



</plugin>


xml-gen
<?xml version="1.0" encoding="UTF-8"?>
<?eclipse version="3.0"?>

<plugin>

  <extension point="org.eclipse.emf.ecore.generated_package">
    <package 
       uri = "http://www.holycityaudio.com/spincad/SpinCAD" 
       class = "com.holycityaudio.spincad.spinCAD.SpinCADPackage"
       genModel = "model/generated/SpinCAD.genmodel" /> 
	
  </extension>



</plugin>


OK the other plugin xml (the one that works) is totally different.

index.php/fa/42274/0/


xml-gen

<?xml version="1.0" encoding="UTF-8"?>
<?eclipse version="3.0"?>

<plugin>

  <extension point="org.eclipse.emf.ecore.generated_package">
    <package 
       uri = "http://www.holycityaudio.com/spincadmenu/SpinCADMenu" 
       class = "com.holycityaudio.spincadmenu.spinCADMenu.SpinCADMenuPackage"
       genModel = "model/generated/SpinCADMenu.genmodel" /> 
	
  </extension>



</plugin>
Re: I have 2 DSLs. When I launch the 2nd instance of Eclipse only 1 of them is active. [message #1853508 is a reply to message #1853507] Wed, 06 July 2022 05:09 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 14434
Registered: July 2009
Senior Member
i mean the plugin.xml of ui projects

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: I have 2 DSLs. When I launch the 2nd instance of Eclipse only 1 of them is active. [message #1853509 is a reply to message #1853508] Wed, 06 July 2022 05:10 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 14434
Registered: July 2009
Senior Member
and no i mean the lauch config of "start runtime eclipse"

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: I have 2 DSLs. When I launch the 2nd instance of Eclipse only 1 of them is active. [message #1853510 is a reply to message #1853509] Wed, 06 July 2022 05:29 Go to previous messageGo to next message
Gary Worsham is currently offline Gary WorshamFriend
Messages: 14
Registered: June 2022
Junior Member
index.php/fa/42276/0/

index.php/fa/42275/0/

index.php/fa/42277/0/

index.php/fa/42278/0/

Re: I have 2 DSLs. When I launch the 2nd instance of Eclipse only 1 of them is active. [message #1853511 is a reply to message #1853510] Wed, 06 July 2022 05:35 Go to previous messageGo to next message
Gary Worsham is currently offline Gary WorshamFriend
Messages: 14
Registered: June 2022
Junior Member
Maybe this?

index.php/fa/42279/0/

Makes no sense though.

index.php/fa/42280/0/
Re: I have 2 DSLs. When I launch the 2nd instance of Eclipse only 1 of them is active. [message #1853512 is a reply to message #1853511] Wed, 06 July 2022 06:01 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 14434
Registered: July 2009
Senior Member
yes you use java 18 there, for reason i dont know, but launch with java 6 for another reason i dont know

xtext supports java 8 and 11 officially and can run with java 17 as target

as i said:
lauch the runtime
check the host osgi console.

also check the plugin.xml and plugin.xml_gen
contents text wise and compare them.


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de

[Updated on: Wed, 06 July 2022 06:07]

Report message to a moderator

Re: I have 2 DSLs. When I launch the 2nd instance of Eclipse only 1 of them is active. [message #1853528 is a reply to message #1853512] Wed, 06 July 2022 15:25 Go to previous messageGo to next message
Gary Worsham is currently offline Gary WorshamFriend
Messages: 14
Registered: June 2022
Junior Member
Yeah, I don't know why I selected this that or the other thing either. I'm pretty sure I selected Java 18 because that's what is on my PC at the moment. There are many places to set this, I guess... too many?
I haven't used OSGI console before, looks like some effort is required to set that up... will be back later.

Thanks!

DL
Re: I have 2 DSLs. When I launch the 2nd instance of Eclipse only 1 of them is active. [message #1853529 is a reply to message #1853528] Wed, 06 July 2022 16:00 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 14434
Registered: July 2009
Senior Member
there is installed jres in eclipse preferences

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: I have 2 DSLs. When I launch the 2nd instance of Eclipse only 1 of them is active. [message #1853534 is a reply to message #1853529] Thu, 07 July 2022 02:53 Go to previous messageGo to next message
Gary Worsham is currently offline Gary WorshamFriend
Messages: 14
Registered: June 2022
Junior Member
Great, thanks, I appear to be past that issue.

Default JRE in Eclipse Preferences is shown:

index.php/fa/42282/0/

After I added this, my second DSL appears to be active.

index.php/fa/42283/0/
  • Attachment: JRE-17.jpg
    (Size: 49.07KB, Downloaded 70 times)
  • Attachment: jdk-18.jpg
    (Size: 54.80KB, Downloaded 71 times)
Re: I have 2 DSLs. When I launch the 2nd instance of Eclipse only 1 of them is active. [message #1853535 is a reply to message #1853534] Thu, 07 July 2022 04:21 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 14434
Registered: July 2009
Senior Member
But why did you configure the project to use 18
(Manifest)
Maybe you wanted 1.8


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: I have 2 DSLs. When I launch the 2nd instance of Eclipse only 1 of them is active. [message #1853551 is a reply to message #1853535] Thu, 07 July 2022 14:46 Go to previous messageGo to next message
Gary Worsham is currently offline Gary WorshamFriend
Messages: 14
Registered: June 2022
Junior Member
As far as using Java 18, I'm just trying to stay current with what is out there.
I am not a full time or professional developer. This is just a hobby.
So at least half of what I am doing is just guessing and hoping for the best.
I thank you very much for your assistance!!!
Re: I have 2 DSLs. When I launch the 2nd instance of Eclipse only 1 of them is active. [message #1853556 is a reply to message #1853551] Thu, 07 July 2022 15:41 Go to previous message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 14434
Registered: July 2009
Senior Member
i propose to consistently use java 11 and also select java 11 in the launch new eclipse runtime dialog

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Previous Topic:Asserting multiple errors with ValidationTestHelper
Next Topic:Can I use multiple xtext files
Goto Forum:
  


Current Time: Thu Feb 09 10:57:39 GMT 2023

Powered by FUDForum. Page generated in 0.02669 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top