Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Check for Updates - The operation cannot be completed(Cannot complete the install because of a conflicting dependency.)
Check for Updates - The operation cannot be completed [message #1851344] Sun, 03 April 2022 15:26 Go to next message
Frank Walter is currently offline Frank WalterFriend
Messages: 4
Registered: June 2013
Junior Member
Hallo

I tried to update my 2022-12 (EDIT 2022-04-04: this was a typo, I ment 2021-12) eclipse with PDT and ran into errors:

Available Updates
 The operation cannot be completed.  See the details.
Details:
Cannot complete the install because of a conflicting dependency.
  Software being installed: PHP Development Tools (PDT) Composer Support 7.2.1.202112011741 (org.eclipse.php.composer.feature.group 7.2.1.202112011741)
  Software currently installed: PHP Development Tools (PDT) SDK Feature 7.2.0.202005271851 (org.eclipse.php.sdk.feature.group 7.2.0.202005271851)
  Only one of the following can be installed at once: 
    Composer UI 7.2.1.202112011741 (org.eclipse.php.composer.ui 7.2.1.202112011741)
    Composer UI 7.2.0.202005271851 (org.eclipse.php.composer.ui 7.2.0.202005271851)
  Cannot satisfy dependency:
    From: PHP Development Tools (PDT) Composer Support 7.2.0.202005271851 (org.eclipse.php.composer.feature.group 7.2.0.202005271851)
    To: org.eclipse.equinox.p2.iu; org.eclipse.php.composer.ui [7.2.0.202005271851,7.2.0.202005271851]
  Cannot satisfy dependency:
    From: PHP Development Tools (PDT) Composer Support 7.2.1.202112011741 (org.eclipse.php.composer.feature.group 7.2.1.202112011741)
    To: org.eclipse.equinox.p2.iu; org.eclipse.php.composer.ui [7.2.1.202112011741,7.2.1.202112011741]
  Cannot satisfy dependency:
    From: PHP Development Tools (PDT) SDK Feature 7.2.0.202005271851 (org.eclipse.php.sdk.feature.group 7.2.0.202005271851)
    To: org.eclipse.equinox.p2.iu; org.eclipse.php.composer.feature.group [7.2.0.202005271851,7.2.0.202005271851]


My only software site is https://download.eclipse.org/releases/latest

What is wrong here?
What can I do?

I dont understand this error :(

Thank for help
frank

Here two screenshots from the errors and my software site management:

index.php/fa/41858/0/
index.php/fa/41857/0/

[Updated on: Mon, 04 April 2022 11:13]

Report message to a moderator

Re: Check for Updates - The operation cannot be completed [message #1851346 is a reply to message #1851344] Sun, 03 April 2022 17:37 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32506
Registered: July 2009
Senior Member
I just installed a fresh old version PHP 2021-12 (because 2022-12 is in the future), and did an update with just that latest like you did, and that works fine. Maybe you had a 2020-12 version? I tried that too and it too updated fine.

It's probably best you install a fresh version to a new location....


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Check for Updates - The operation cannot be completed [message #1851374 is a reply to message #1851346] Mon, 04 April 2022 11:19 Go to previous messageGo to next message
Frank Walter is currently offline Frank WalterFriend
Messages: 4
Registered: June 2013
Junior Member
Ed Merks wrote on Sun, 03 April 2022 13:37
I just installed a fresh old version PHP 2021-12 (because 2022-12 is in the future),
...
It's probably best you install a fresh version to a new location....

Sorry, that was a typo (made an EDIT in my original post for it), ment 2021-12.

You mean installing eclipse freshly to a new location?
Thanks already.
Re: Check for Updates - The operation cannot be completed [message #1851380 is a reply to message #1851374] Mon, 04 April 2022 13:57 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 32506
Registered: July 2009
Senior Member
Yes, you could even install over an existing location, but that's a bit riskier so better a new location.

Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:How to unistall OpenJDK17U-jdk_aarch64_mac_hotspot_17.0.2_8.pkg
Next Topic:problem with MacOS JDK 8 checksum
Goto Forum:
  


Current Time: Thu Oct 06 03:08:40 GMT 2022

Powered by FUDForum. Page generated in 0.03448 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top