Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Build Ant project with a different JRE: "JNI error has occurred"
Build Ant project with a different JRE: "JNI error has occurred" [message #1851272] Fri, 01 April 2022 08:37 Go to next message
Marco A is currently offline Marco AFriend
Messages: 4
Registered: March 2022
Junior Member
Hi,
I try to run an Ant script with a different JRE, but when I select the installed JRE it fails with "Error: A JNI error has occurred, please check your installation and try again".

If I use "Run in the same JRE as the workspace" it works but with a bad JRE...

I also try to set a JAVA_HOME in the tab "Enviroment" but nothing change.


I use Eclipse 2022-03

Thanks in advance
Re: Build Ant project with a different JRE: "JNI error has occurred" [message #1851354 is a reply to message #1851272] Mon, 04 April 2022 03:44 Go to previous messageGo to next message
Barrie Treloar is currently offline Barrie TreloarFriend
Messages: 55
Registered: July 2009
Member
Is this bug you're problem?
https://bugs.eclipse.org/bugs/show_bug.cgi?id=579317

It's marked as fixed but I can't see what the fix is yet.
Re: Build Ant project with a different JRE: "JNI error has occurred" [message #1851360 is a reply to message #1851354] Mon, 04 April 2022 06:25 Go to previous messageGo to next message
Marco A is currently offline Marco AFriend
Messages: 4
Registered: March 2022
Junior Member
Yes, it could be.
I don't know if I well understand, but with the latest release of eclipse is no more build Ant project with Java 8 but only with Java 11+?
Re: Build Ant project with a different JRE: "JNI error has occurred" [message #1851362 is a reply to message #1851360] Mon, 04 April 2022 07:19 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32506
Registered: July 2009
Senior Member
Yes, that is my interpretation of what I see. With breaking changes coming in Java 18 and preparations needed for that, changes were made that make it does not not work with < Java 11 and now (for Eclipse 4.24/2022-06) it will explicitly say that it doesn't work rather than failing cryptically as it does currently...

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Build Ant project with a different JRE: "JNI error has occurred" [message #1854279 is a reply to message #1851272] Wed, 10 August 2022 08:12 Go to previous messageGo to next message
Vamsi Kondaparthi is currently offline Vamsi KondaparthiFriend
Messages: 1
Registered: August 2022
Junior Member
Hi Team,

I am facing the same issue, could you please let me know how to resolve it. Thanks.

Regards,
Vamsi
Re: Build Ant project with a different JRE: "JNI error has occurred" [message #1854285 is a reply to message #1854279] Wed, 10 August 2022 14:43 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 32506
Registered: July 2009
Senior Member
See https://bugs.eclipse.org/bugs/show_bug.cgi?id=579317#c29

Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:When you press Ctrl + C, you jump to the definition of the method
Next Topic:Error 500
Goto Forum:
  


Current Time: Thu Oct 06 04:12:38 GMT 2022

Powered by FUDForum. Page generated in 0.05735 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top