Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse IDE java-2021-06-R-linux-gtk-x86_64 Installer Fails(Eclipse Installer Fails With JVM Terminated Exit Code=127)
Eclipse IDE java-2021-06-R-linux-gtk-x86_64 Installer Fails [message #1850217] Tue, 22 February 2022 01:02 Go to next message
Ravi Kumar MG is currently offline Ravi Kumar MGFriend
Messages: 6
Registered: February 2022
Junior Member
index.php/fa/41688/0/I am On Oracle Linux 7 and Trying To Install Eclipse IDE For Java.
Linux (4.1.12-61.1.18.el7uek.x86_64)
1 st I Tried With Latest Version 2021-12
and Later With 2021-09 and 2021-06 All Failed With
JVM Terminated Exit Code=127.
I Tryed Changing
1) My Default Java Version to 1.8 and 11
2)Tryed with -vm <Java Path> in elcipse-inst.ini
3)Tryed with MOZILLA_HOME="". in config.in

Same Downloads Works Perfectly On My Rocky Linux 8 Machine
But Fails On My Oracle Linux 7 Machine
It Will Be Help full If Someone Shows
What I am Doing Wrong or Missing To Do.
index.php/fa/41688/0/
Re: Eclipse IDE java-2021-06-R-linux-gtk-x86_64 Installer Fails [message #1850218 is a reply to message #1850217] Tue, 22 February 2022 01:06 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4264
Registered: July 2009
Senior Member

What happens with the installer for the current release, 2021-12?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Eclipse IDE java-2021-06-R-linux-gtk-x86_64 Installer Fails [message #1850219 is a reply to message #1850218] Tue, 22 February 2022 01:14 Go to previous messageGo to next message
Ravi Kumar MG is currently offline Ravi Kumar MGFriend
Messages: 6
Registered: February 2022
Junior Member
Same Thing Happens
Screen Shot Attached.
Thank You.

[Updated on: Tue, 22 February 2022 01:15]

Report message to a moderator

Re: Eclipse IDE java-2021-06-R-linux-gtk-x86_64 Installer Fails [message #1850222 is a reply to message #1850219] Tue, 22 February 2022 06:59 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32491
Registered: July 2009
Senior Member
I suspect it's a problem related to the GTK version on your machine because it sounds like this

https://bugs.eclipse.org/bugs/show_bug.cgi?id=174547

Note the installer is using its own embedded JRE.

You could download a package from here:

https://www.eclipse.org/downloads/packages/

But that's highly likely to suffer exactly the same problem...


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Eclipse IDE java-2021-06-R-linux-gtk-x86_64 Installer Fails [message #1850238 is a reply to message #1850222] Tue, 22 February 2022 12:15 Go to previous messageGo to next message
Ravi Kumar MG is currently offline Ravi Kumar MGFriend
Messages: 6
Registered: February 2022
Junior Member
@Ed Merks Thank You For Your Time
I Downloaded Packages From Eclipse Downloads Page.

Re: Eclipse IDE java-2021-06-R-linux-gtk-x86_64 Installer Fails [message #1850250 is a reply to message #1850222] Tue, 22 February 2022 17:51 Go to previous messageGo to next message
Ravi Kumar MG is currently offline Ravi Kumar MGFriend
Messages: 6
Registered: February 2022
Junior Member
Ed Merks wrote on Tue, 22 February 2022 06:59
I suspect it's a problem related to the GTK version on your machine because it sounds like this

https://bugs.eclipse.org/bugs/show_bug.cgi?id=174547

Note the installer is using its own embedded JRE.

You could download a package from here:

https://www.eclipse.org/downloads/packages/

But that's highly likely to suffer exactly the same problem...


Thank You Ed Merks
You Are Right Latest Packages Too Fail After Showing The Splash.

But Version 2020-03 Works For Me.

This Oracle Linux 7 and Eclipse 2020-3 Only Machine Is Going To Be Used
To Manage An Old Project Under Maintenance.Grand Enough For Me.

Solved.
Re: Eclipse IDE java-2021-06-R-linux-gtk-x86_64 Installer Fails [message #1850251 is a reply to message #1850250] Tue, 22 February 2022 19:10 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32491
Registered: July 2009
Senior Member
It's probably an issue with an old GTK version on your OS. What GTK version do you have?

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Eclipse IDE java-2021-06-R-linux-gtk-x86_64 Installer Fails [message #1850254 is a reply to message #1850251] Wed, 23 February 2022 02:19 Go to previous messageGo to next message
Ravi Kumar MG is currently offline Ravi Kumar MGFriend
Messages: 6
Registered: February 2022
Junior Member
@ Ed Merks


gtk2-2.24.28-8.el7.x86_64
gtk3-3.14.13-20.el7.x86_64

I Get These Package Names From
yum -qa | grep gtk
Re: Eclipse IDE java-2021-06-R-linux-gtk-x86_64 Installer Fails [message #1850256 is a reply to message #1850254] Wed, 23 February 2022 08:03 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32491
Registered: July 2009
Senior Member
Yes that looks way too old:

https://www.eclipse.org/swt/faq.php#gtkstartup


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Eclipse IDE java-2021-06-R-linux-gtk-x86_64 Installer Fails [message #1850272 is a reply to message #1850256] Wed, 23 February 2022 13:03 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4264
Registered: July 2009
Senior Member

2020-03 was Eclipse 4.15 and, no surprise, according to the document Ed referred to it was the last release to officially target/support gtk3 3.14.

Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Wed, 23 February 2022 13:04]

Report message to a moderator

Re: Eclipse IDE java-2021-06-R-linux-gtk-x86_64 Installer Fails [message #1850278 is a reply to message #1850272] Wed, 23 February 2022 16:11 Go to previous message
Ravi Kumar MG is currently offline Ravi Kumar MGFriend
Messages: 6
Registered: February 2022
Junior Member
Nitin Dahyabhai
After Updating GTK Eclipse Runs Well But After Reboot
Oracle Linux Failed Before Login Screen.
So I Formated The Machine and Moved To Rocky Linux 8.5
The Reason For Above Trials On Oracle 7 Is I Want
Oracle 11g DB On This Machine To Debug.
Now I am Using Virtualbox With Windows+ Oracle 11g.
Previous Topic:Servlet not working after deployment on Apache Tomcat 9.0
Next Topic:Assistance required- Compatibility issue with Eclipse IDE and Maven
Goto Forum:
  


Current Time: Sun Sep 25 08:31:33 GMT 2022

Powered by FUDForum. Page generated in 0.03019 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top