Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse 2021-12: Java 17 JRE not avilable?
Eclipse 2021-12: Java 17 JRE not avilable? [message #1849516] Sat, 22 January 2022 20:46
Max Muster is currently offline Max MusterFriend
Messages: 11
Registered: November 2020
Junior Member
Hi,

I installed the new Eclipse 2021-12, but when I try to create a new" File -> New -> Java Project" with "JavaSE-17" as a value for "Use an execution environment JRE" I get the following warning after I click on "Next":

"Build path entry is missing: org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-17"

At "Properties (of the project) -> Java Build Path" at "Libaries -> Classpath" it then says "JRE System Library [JavaSE-17] (unbound)".

I guess "unbound" is not good? I thought the newest Eclipse comes with a Java 17 JRE?

At "JRE System Library [JavaSE-17] (unbound) -> Edit -> Environments" at "Execution Environemtn" on the left side I can select JavaSE-17, but at "Compatible JREs" on the right side there is nothing to select.

It would be great if you could help, thank you!

[Updated on: Sat, 22 January 2022 21:01]

Report message to a moderator

Previous Topic:Cannot download
Next Topic:Error: Could not find or load main class NewMain.Main
Goto Forum:
  


Current Time: Thu Oct 06 04:20:09 GMT 2022

Powered by FUDForum. Page generated in 0.04529 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top