Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Strange launch and build issue with XText antlr dependency and Eclipse products
Strange launch and build issue with XText antlr dependency and Eclipse products [message #1848904] Wed, 22 December 2021 20:22 Go to next message
Reiner Jung is currently offline Reiner JungFriend
Messages: 10
Registered: June 2010
Location: Uni Kiel
Junior Member
Hi folks,

I have searched for help and read documentation, tutorials and code for the last two days including Lars Vogel's website (https://www.vogella.com/tutorials/EclipsePlugin/article.html). However, I cannot figure out why the problem occurs.

I have created a DSL with XText with support for Eclipse, LSP and a OSGi based command line generator. The Eclipse plugins work in Eclipse with a normal run configuration, the LSP parts work fine too in other editors and I can run the command line tool with a run configuration without any problems. However, when I create a product - and it does not mapper which tutorial I follow so far - the result is the same. When I create a product file in its own project or inside the command line project and then try to run it via "Launch an Eclipse application" in the Overview tab of the product, it claims that it cannot satisfy the dependency org.antlr.runtime versions [3.2.0, 3.2.1).
Under the "Contents" tab "org.antlr.runtime" is listed without a version number and in my Eclipse installation org.antlr.runtime is available as 3.20 and 4.7 versions. When I force a version number under contents for org.antlr.runtime (3.2.0) I get a warning there. So it seems it cannot find that dependency, but it is available. I also created a target platform configuration and it is in there too.

When I ignore the warning and try to run the whole caboodle I get the following error log (see attachment for full log).

Framework arguments:  -product org.oceandsl.configuration.cli.cp_application -clearPersistedState
Command-line arguments:  -product org.oceandsl.configuration.cli.cp_application -data /home/reiner/eclipse-workspace-conf-dsl/../runtime-org.oceandsl.configuration.cli.product(2) -dev file:/home/reiner/eclipse-workspace-conf-dsl/.metadata/.plugins/org.eclipse.pde.core/org.oceandsl.configuration.cli.product (2)/dev.properties -os linux -ws gtk -arch x86_64 -consoleLog -clearPersistedState

!ENTRY org.eclipse.xtext.xbase 4 0 2021-12-22 21:07:14.890
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.xtext.xbase [111]
  Unresolved requirement: Require-Bundle: org.antlr.runtime; bundle-version="[3.2.0,3.2.1)"
  Unresolved requirement: Require-Bundle: org.eclipse.xtext.common.types; visibility:="reexport"
    -> Bundle-SymbolicName: org.eclipse.xtext.common.types; bundle-version="2.25.0.v20210301-0909"; singleton:="true"
       org.eclipse.xtext.common.types [360]
         Unresolved requirement: Require-Bundle: org.eclipse.xtext
           -> Bundle-SymbolicName: org.eclipse.xtext; bundle-version="2.25.0.v20210301-0843"; singleton:="true"
              org.eclipse.xtext [359]
                Unresolved requirement: Require-Bundle: org.antlr.runtime; bundle-version="[3.2.0,3.2.1)"; visibility:="reexport"
  Unresolved requirement: Require-Bundle: org.eclipse.xtext
    -> Bundle-SymbolicName: org.eclipse.xtext; bundle-version="2.25.0.v20210301-0843"; singleton:="true"


The whole project is available at https://git.se.informatik.uni-kiel.de/oceandsl/cp-dsl/-/tree/3-use-proper-command-line-parser-for-cli-compiler
However, I doubt that this can be seen as a minimal example of the issue.

My question are:
- Why does the product configuration and launcher does not find the correct org.antlr.runtime bundle?
- What should I check to narrow the issue down?
- Are there some strange side effect of using tycho/maven for the build? (I doubt that, as the Launch button is in Eclipse)

Any insights are welcome
Reiner
Re: Strange launch and build issue with XText antlr dependency and Eclipse products [message #1848914 is a reply to message #1848904] Thu, 23 December 2021 09:33 Go to previous message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 14352
Registered: July 2009
Senior Member
where is your product definition file? did you try to load plugins and target platform in a fresh workspace. maybe something is broken in yours

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Previous Topic:Xtext 2.26.0.M2 is available
Next Topic:Defined 2-way link-list xtext grammar issues
Goto Forum:
  


Current Time: Fri Sep 30 21:31:56 GMT 2022

Powered by FUDForum. Page generated in 0.02114 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top