Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » FrameworkEvent ERROR(Error )
FrameworkEvent ERROR [message #1844412] Mon, 13 September 2021 11:56
David Haufe is currently offline David HaufeFriend
Messages: 1
Registered: September 2021
Junior Member
Hello,

I installed some packages from https://download.eclipse.org/oomph/archive/reports/download.eclipse.org/releases/2021-09/index/org.eclipse.wst.common.modulecore_1.3.102.v202103232321.html to get the a missing framework for the darkest dark plugin..

Since I didn't know exactly which one was the right one, I just installed all available ones :/

After that I was invited to restart eclipse, and after the restart I was missing the marketplace and add software unter "help"..

Then I have restarted the PC, but then eclipse wont start anymore..

I get this error log:
!SESSION 2021-09-13 13:45:05.537 -----------------------------------------------
eclipse.buildId=7.0.4
java.version=1.8.0_301
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=de_DE
Command-line arguments: -os win32 -ws win32 -arch x86_64

!ENTRY org.eclipse.equinox.ds 4 0 2021-09-13 13:45:07.965
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.equinox.ds [5]
Unresolved requirement: Import-Package: org.eclipse.equinox.internal.util.event; version="1.0.0"

at org.eclipse.osgi.container.Module.start(Module.java:463)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.lambda$1(ModuleContainer.java:1834)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1829)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1777)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1739)
at org.eclipse.osgi.container.SystemModule.startWorker(SystemModule.java:269)
at org.eclipse.osgi.container.Module.doStart(Module.java:605)
at org.eclipse.osgi.container.Module.start(Module.java:468)
at org.eclipse.osgi.container.SystemModule.start(SystemModule.java:193)
at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:439)
at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:458)
at org.eclipse.osgi.launch.Equinox.start(Equinox.java:139)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:338)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:251)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:659)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:596)
at org.eclipse.equinox.launcher.Main.run(Main.java:1467)
at org.eclipse.equinox.launcher.Main.main(Main.java:1440)

!ENTRY org.eclipse.equinox.event 4 0 2021-09-13 13:45:07.965
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.equinox.event [6]
Unresolved requirement: Import-Package: org.osgi.service.event; version="[1.3.0,1.5.0)"

at org.eclipse.osgi.container.Module.start(Module.java:463)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.lambda$1(ModuleContainer.java:1834)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1829)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1777)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1739)
at org.eclipse.osgi.container.SystemModule.startWorker(SystemModule.java:269)
at org.eclipse.osgi.container.Module.doStart(Module.java:605)
at org.eclipse.osgi.container.Module.start(Module.java:468)
at org.eclipse.osgi.container.SystemModule.start(SystemModule.java:193)
at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:439)
at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:458)
at org.eclipse.osgi.launch.Equinox.start(Equinox.java:139)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:338)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:251)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:659)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:596)
at org.eclipse.equinox.launcher.Main.run(Main.java:1467)
at org.eclipse.equinox.launcher.Main.main(Main.java:1440)

!ENTRY org.eclipse.equinox.simpleconfigurator 4 0 2021-09-13 13:45:07.965
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.equinox.simpleconfigurator [7]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=11))"

at org.eclipse.osgi.container.Module.start(Module.java:463)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.lambda$1(ModuleContainer.java:1834)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1829)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1777)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1739)
at org.eclipse.osgi.container.SystemModule.startWorker(SystemModule.java:269)
at org.eclipse.osgi.container.Module.doStart(Module.java:605)
at org.eclipse.osgi.container.Module.start(Module.java:468)
at org.eclipse.osgi.container.SystemModule.start(SystemModule.java:193)
at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:439)
at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:458)
at org.eclipse.osgi.launch.Equinox.start(Equinox.java:139)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:338)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:251)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:659)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:596)
at org.eclipse.equinox.launcher.Main.run(Main.java:1467)
at org.eclipse.equinox.launcher.Main.main(Main.java:1440)

!ENTRY org.eclipse.osgi 4 0 2021-09-13 13:45:07.981
!MESSAGE Das Produktpaket initial@reference:file:plugins/org.eclipse.equinox.ds_1.4.400.v20160226-2036.jar wurde nicht aufgelöst.

!ENTRY org.eclipse.osgi 4 0 2021-09-13 13:45:07.981
!MESSAGE Das Produktpaket initial@reference:file:plugins/org.eclipse.equinox.event_1.6.0.v20210212-1143.jar wurde nicht aufgelöst.

!ENTRY org.eclipse.osgi 4 0 2021-09-13 13:45:07.981
!MESSAGE Das Produktpaket initial@reference:file:plugins/org.eclipse.equinox.simpleconfigurator_1.4.0.v20210315-2228.jar wurde nicht aufgelöst.

!ENTRY org.eclipse.equinox.event 2 0 2021-09-13 13:45:07.981
!MESSAGE Could not resolve module: org.eclipse.equinox.event [6]
Unresolved requirement: Import-Package: org.osgi.service.event; version="[1.3.0,1.5.0)"


!ENTRY org.eclipse.equinox.simpleconfigurator 2 0 2021-09-13 13:45:07.981
!MESSAGE Could not resolve module: org.eclipse.equinox.simpleconfigurator [7]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=11))"


!ENTRY org.eclipse.equinox.ds 2 0 2021-09-13 13:45:07.981
!MESSAGE Could not resolve module: org.eclipse.equinox.ds [5]
Unresolved requirement: Import-Package: org.eclipse.equinox.internal.util.event; version="1.0.0"


!ENTRY org.eclipse.osgi 4 0 2021-09-13 13:45:07.997
!MESSAGE Anwendungsfehler
!STACK 1
java.lang.IllegalStateException: Der Anwendungsservice kann nicht erreicht werden. Stellen Sie sicher, dass das Produktpaket 'org.eclipse.core.runtime' aufgelöst und gestartet wurde (siehe 'config.ini').
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:81)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:401)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:659)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:596)
at org.eclipse.equinox.launcher.Main.run(Main.java:1467)
at org.eclipse.equinox.launcher.Main.main(Main.java:1440)

I used the qde 7.0 Momentic ( QNX IDE).
Previous Topic:Spell Check not working in .txt file
Next Topic:eclipse throws JRE error
Goto Forum:
  


Current Time: Fri Jan 28 22:42:31 GMT 2022

Powered by FUDForum. Page generated in 0.02610 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top