Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » [Solved] Cannot understand toolchain configuration
[Solved] Cannot understand toolchain configuration [message #1844201] Mon, 06 September 2021 09:43 Go to next message
Jack White is currently offline Jack WhiteFriend
Messages: 1
Registered: September 2021
Junior Member
Solved: You must add the toolchain binaries directory as the compiler directory, the tool directory *and* to the path.

I am struggling to get the ARM GCC toolchain working in Eclipse 2021-06 (4.20.0) on Ubuntu 20.04.

Previously, I had installed the ARM GCC toolchain from the Ubuntu software repos, however, this installation does not include GDB, so I eventually removed those packages and downloaded the latert full toolchain from the ARM website.

I have installed the toolchain in /opt/gcc-arm-none-eabi-10.3-2021.0. The binaries are in the bin/ subdirectory. I have added this directory to my PATH environment variable, so I am able to run the tools from the command line.

I cannot, however, build my project in Eclipse:
/bin/sh: arm-none-eabi-gcc: command not found

I have investigated adding the toolchain to Eclipse in Project->Properties->C/C++ Build->Settings->Toolchains.

Name: GNU MCU Eclipse ARM Embedded GCC (arm-none-eabi-gcc)
Toolchain path: /opt/gcc-arm-none-eabi-10.3-2021.07/bin
Build tools path: /opt/gcc-arm-none-eabi-10.3-2021.07/bin

However, I do notice that in Project->Properties->C/C++ Build->Tool Chain Editor, the current toolchain is ARM Cross GCC, and the Used Tools list reads: "Cross ARM GNU Assembler; Cross ARM GNU C Compiler; etc, etc"

"Arm Cross GCC" is not a toolchain listed in the Name listbox of Project->Properties->C/C++ Build->Settings->Toolchains.

This is my current state, and still the build does not find the toolchain binaries. What am I doing wrong? Is there one central place in Eclipse where I can definitively configure the toolchain?

[Updated on: Mon, 06 September 2021 15:32]

Report message to a moderator

Re: [Solved] Cannot understand toolchain configuration [message #1844777 is a reply to message #1844201] Fri, 24 September 2021 16:54 Go to previous message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 684
Registered: August 2014
Senior Member
Please jettison the new tools installation and install the Ubuntu repository compiler setup back. For GDB, install the gdb-multiarch package from the Ubuntu repo.
The debugger can read the target type from the binary file header and adjust itself accordingly. There are the set arch and show arch commands, but I have seldom needed them.


--

Tauno Voipio
Previous Topic:Building class - what are these for - Final class , Unit test ?
Next Topic: arm-linux-gnueabihf-g++ "not found " error
Goto Forum:
  


Current Time: Sat Nov 27 23:29:01 GMT 2021

Powered by FUDForum. Page generated in 0.02808 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top