Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse plugins(Plugins not appearing on Eclipse)
Eclipse plugins [message #1844108] Wed, 01 September 2021 13:51 Go to next message
Vincent Mulhall is currently offline Vincent MulhallFriend
Messages: 2
Registered: September 2021
Junior Member
When we bootstrap our application, we pull down a development environment. Eclipse lives inside this environment, as well as a number of plugins (Tomcat, Checkstyle, Eclemma, etc.). The binaries for these plugins are stored on our network and are pulled down into the eclipse-extensions folder. We do this so that developers don't have to pull them down from the Marketplace every time they set up a new environment.

The version of Eclipse we're using is 2020-06, the OS is BigSur, and the version of Java is 1.8.

When I launch eclipse, all bar one of the plugins is available. I've gone around in circles trying to determine why the other plugins are not viewable.

Any pointers welcome!
Re: Eclipse plugins [message #1844109 is a reply to message #1844108] Wed, 01 September 2021 13:59 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4169
Registered: July 2009
Senior Member

Could it require Java 11? The Platform has for nearly a year, so more and more plug-ins are requiring it in their newer versions.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Eclipse plugins [message #1844110 is a reply to message #1844109] Wed, 01 September 2021 14:43 Go to previous message
Vincent Mulhall is currently offline Vincent MulhallFriend
Messages: 2
Registered: September 2021
Junior Member
Thanks for the quick reply. As I said above, we're using 2020-06 which is Eclipse 4.16. This page (https://wiki.eclipse.org/Eclipse/Installation) would suggest that Java 1.8 is the minimum version required. The plugins we're using would not be any more recent than the Eclipse version itself. Hope this makes sense.

I have my JAVA_HOME pointed to 1.8 before launching Eclipse. Does Eclipse even look at the JAVA_HOME variable? Also, just wondering if there are any other variables that need to be set when launching Eclipse.
Previous Topic:Unable to push to repo via eclipse
Next Topic:Errors importing old projects into new workspace
Goto Forum:
  


Current Time: Fri Jan 28 23:26:28 GMT 2022

Powered by FUDForum. Page generated in 0.04075 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top