Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Unable to install BIRT 4.9(Problem installing BIRT 4.9 on eclipse 2021-06 or 2021-03)
Unable to install BIRT 4.9 [message #1843365] Mon, 26 July 2021 09:44 Go to next message
Alfredo De Ferrari is currently offline Alfredo De FerrariFriend
Messages: 3
Registered: July 2021
Junior Member
Hi,

I'm having issues installing BIRT 4.9 from https://download.eclipse.org/birt/update-site/snapshot/ using the « Install new software ».

I've tried installing it on Eclipse 2021-06 and 2021-03, but I get the following error :

Cannot complete the install because of a conflicting dependency.
Software being installed: BIRT Engine Runtime Feature 4.9.0.v202107212308 (org.eclipse.birt.engine.runtime.feature.group 4.9.0.v202107212308)
Software currently installed: Eclipse IDE for Java Developers 4.20.0.20210612-1200 (epp.package.java 4.20.0.20210612-1200)
Only one of the following can be installed at once:
Install/Update Configurator 3.4.800.v20210415-1314 (org.eclipse.update.configurator 3.4.800.v20210415-1314)
Install/Update Configurator 3.4.700.v20200907-1237 (org.eclipse.update.configurator 3.4.700.v20200907-1237)
Install/Update Configurator 3.4.200.v20190218-1148 (org.eclipse.update.configurator 3.4.200.v20190218-1148)
Cannot satisfy dependency:
From: Eclipse IDE for Java Developers 4.20.0.20210612-1200 (epp.package.java 4.20.0.20210612-1200)
To: org.eclipse.equinox.p2.iu; org.eclipse.platform.feature.group [4.20.0.v20210611-1600,4.20.0.v20210611-1600]
Cannot satisfy dependency:
From: BIRT Engine Runtime Feature 4.9.0.v202107212308 (org.eclipse.birt.engine.runtime.feature.group 4.9.0.v202107212308)
To: org.eclipse.equinox.p2.iu; org.eclipse.update.configurator [3.4.200.v20190218-1148,3.4.200.v20190218-1148]
Cannot satisfy dependency:
From: Eclipse Platform 4.20.0.v20210611-1600 (org.eclipse.platform.feature.group 4.20.0.v20210611-1600)
To: org.eclipse.equinox.p2.iu; org.eclipse.rcp.feature.group [4.20.0.v20210611-1600,4.20.0.v20210611-1600]
Cannot satisfy dependency:
From: Eclipse RCP 4.20.0.v20210611-1600 (org.eclipse.rcp.feature.group 4.20.0.v20210611-1600)
To: org.eclipse.equinox.p2.iu; org.eclipse.update.configurator [3.4.800.v20210415-1314,3.4.800.v20210415-1314]

Does anyone have a workaround ?

Many thanks
Re: Unable to install BIRT 4.9 [message #1843383 is a reply to message #1843365] Tue, 27 July 2021 08:26 Go to previous messageGo to next message
Colin Sutton is currently offline Colin SuttonFriend
Messages: 121
Registered: July 2009
Senior Member
4.8 is the latest production release. Too many eclipse components have changed and too few people have time to contribute to fixing it.
It's possible a new release will be ready later this year.
Re: Unable to install BIRT 4.9 [message #1843384 is a reply to message #1843383] Tue, 27 July 2021 08:43 Go to previous messageGo to next message
Alfredo De Ferrari is currently offline Alfredo De FerrariFriend
Messages: 3
Registered: July 2021
Junior Member
Hi Colin,

Thanks for your reply.
Where can I download version 4.8 ?
I'm using the « install new software » feature from Eclipse on ubuntu 20.04.

I didn't find it under : https://download.eclipse.org/birt/update-site/

nor : https://download.eclipse.org/birt/downloads/drops/

PS : I don't have an earlier version installed. I'm installing it from scratch.

Thanks again
Re: Unable to install BIRT 4.9 [message #1843445 is a reply to message #1843384] Fri, 30 July 2021 04:52 Go to previous messageGo to next message
Colin Sutton is currently offline Colin SuttonFriend
Messages: 121
Registered: July 2009
Senior Member
Google showed me this:
https://download.eclipse.org/birt/downloads/drops/I-R1-4.8.0-201806041644/
Re: Unable to install BIRT 4.9 [message #1843774 is a reply to message #1843445] Tue, 17 August 2021 12:18 Go to previous messageGo to next message
Alfredo De Ferrari is currently offline Alfredo De FerrariFriend
Messages: 3
Registered: July 2021
Junior Member
Thanks for your reply : will test asap !
Re: Unable to install BIRT 4.9 [message #1844632 is a reply to message #1843365] Sat, 18 September 2021 21:37 Go to previous message
Doug Averch is currently offline Doug AverchFriend
Messages: 11
Registered: July 2017
Junior Member
Try this release:
https://github.com/SaMuellerDLR/birt/releases
Previous Topic:BIRT with Latest Eclipse Verion
Next Topic:Eclipse not build correct new project, always build project old , pleasy help.
Goto Forum:
  


Current Time: Wed Sep 29 00:18:43 GMT 2021

Powered by FUDForum. Page generated in 0.01758 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top