Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse starts with blank window on Mac(Eclipse installation problems)
Eclipse starts with blank window on Mac [message #1842751] Wed, 30 June 2021 13:38 Go to next message
Frä Fröhlich is currently offline Frä FröhlichFriend
Messages: 18
Registered: June 2021
Junior Member
I installed Eclipse 2018(https://www.eclipse.org/downloads/packages/release/2018-09/r/eclipse-ide-java-and-dsl-developers). I need this specific version and had it running on my old Mac already (new Mac has fresh installation).
I use Java 8 (openjdk version "1.8.0_292"
OpenJDK Runtime Environment (AdoptOpenJDK)(build 1.8.0_292-b10)
OpenJDK 64-Bit Server VM (AdoptOpenJDK)(build 25.292-b10, mixed mode))

1st I can't start it from double clicking, but have to use cli for it(can't find java home). I have seen some posts on how to fix this, so this is not my issue.

2nd: When I open Eclipse I get a blank page (see appendix).
I am unable to do anything. When I click on menu items (e.g. preferences) nothing happens.
I also started eclipse from cli and didn't see anything specific in the execution logs.

[Updated on: Wed, 30 June 2021 14:03]

Report message to a moderator

Re: Eclipse starts with blank window on Mac [message #1842754 is a reply to message #1842751] Wed, 30 June 2021 14:37 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31957
Registered: July 2009
Senior Member
I believe such an old version of Eclipse will not run on the latest MacOS. I'm not sure why you need this specific version; you should revisit/reconsider that need.

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Eclipse starts with blank window on Mac [message #1842785 is a reply to message #1842754] Thu, 01 July 2021 11:09 Go to previous messageGo to next message
Frä Fröhlich is currently offline Frä FröhlichFriend
Messages: 18
Registered: June 2021
Junior Member
I actually had it running on the same Mac with the same OS Version already :(

I tried multiple other eclipse Versions and none worked for the dependencies in my Project.
Re: Eclipse starts with blank window on Mac [message #1842788 is a reply to message #1842785] Thu, 01 July 2021 11:36 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31957
Registered: July 2009
Senior Member
Perhaps you're assuming that your project dependencies must be satisfied by what's in your installation. You can use a newer version of Eclipse and populate the target platform with older versions of the dependencies.

I really don't know what to say about the fact you can't get it to work on your new mac where you had it working before.... What changed since you had it running?


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:BIRT report designer not getting installed
Next Topic:Application Android whit Server GlassFish
Goto Forum:
  


Current Time: Sun Jul 25 04:03:15 GMT 2021

Powered by FUDForum. Page generated in 0.07767 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top