Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Eclipse Photon not working after updating MacOS to 10.14(Getting "Failed to create the Java Virtual Machine" error on launch)
Eclipse Photon not working after updating MacOS to 10.14 [message #1840625] Wed, 21 April 2021 02:31 Go to next message
Ken Krugler is currently offline Ken KruglerFriend
Messages: 3
Registered: July 2009
Junior Member
I upgraded from MacOS 10.12 to 10.14, and following that I get the dreaded "Failed to create the Java Virtual Machine" error when trying to launch Eclipse.

I found various suggestions for how to fix this problem, including editing the Info.plist file to add an Eclipse:-vm <path to java tool> entry.

I did that (pointing it at OpenJDK 1.8.0_282), and now Eclipse launches, but I get an empty IDE window with just the toolbar. If I try opening other windows (even "About Eclipse") nothing gets displayed.

Any suggestions for how to trouble-shoot this?

Thanks!

-- Ken
Re: Eclipse Photon not working after updating MacOS to 10.14 [message #1840626 is a reply to message #1840625] Wed, 21 April 2021 03:04 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4060
Registered: July 2009
Senior Member

Your new version of macOS is newer than Photon, and Eclipse requires compatibility changes made in later releases to work properly in it. The current release is 2021-03, containing Eclipse 4.19.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Eclipse Photon not working after updating MacOS to 10.14 [message #1840666 is a reply to message #1840626] Wed, 21 April 2021 15:09 Go to previous message
Ken Krugler is currently offline Ken KruglerFriend
Messages: 3
Registered: July 2009
Junior Member
Thanks Nitin, that worked! And it's great that the new installer (in advanced mode) lets you set up the JVM to use as part of the process.
Previous Topic:Help with calculator program
Next Topic:Run Configuration that spawns a new shell process
Goto Forum:
  


Current Time: Tue Jun 15 07:55:00 GMT 2021

Powered by FUDForum. Page generated in 0.02200 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top