Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Orbit » Ant bundle requires Java version "=1.8" instead of ">=1.8"(Problems building anything requiring Ant on Java 9+)
Ant bundle requires Java version "=1.8" instead of ">=1.8" [message #1840429] Thu, 15 April 2021 06:58
Alexander Kriegisch is currently offline Alexander KriegischFriend
Messages: 1
Registered: April 2021
Junior Member
Disclaimer: I have never used OSGi before and am just trying to find out why the build of a product I am interested in is not working.

The situation is as follows:

  • I need to upgrade a product using Eclipse OSGi bundles.
  • One upgraded bundle contains Java 11 class files, i.e. I need to build running JDK 11+ for obvious reasons.
  • Other than the compiler recognising the byte code version, I use not Java 9+ features at all, my build target is 1.8.
  • One indirectly required plugin Tycho pulls is Apache Ant from Orbit. The concrete version resolved is 1.10.9.v20201106-1946.
  • According to this resource, the Ant bundle requires an exact match on Java version 1.8 according to the 'requiredProperties' tag.
  • I do not understand this restriction, as Ant itself just requires Java 1.8+ to run, I use it in other projects with up to Java 16 without any issues.

Could someone please fix the bundle descriptor to '>=1.8' instead of '=1.8'? Otherwise neither I nor anyone else can ever build anything requiring Ant with Java 9+.
Previous Topic:poi-ooxml-schemas and ooxml-schemas
Next Topic:Access Forbidden on Orbit download
Goto Forum:

Current Time: Wed Sep 22 23:09:03 GMT 2021

Powered by FUDForum. Page generated in 0.01532 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top