Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » NatTable » Possible Bug Report for Single Select + Use Checkbox Combobox Cell Editors
Possible Bug Report for Single Select + Use Checkbox Combobox Cell Editors [message #1840042] Tue, 06 April 2021 06:06 Go to next message
Louis Detweiler is currently offline Louis DetweilerFriend
Messages: 76
Registered: August 2017
Member
Hi,

We use NatTable in an RCP application we are developing and it is great!

We came across what we thought may be a bug involving the combination of using checkboxes in the Combobox cell editors while also NOT using multiselect.

However, we are currently using NatTable 1.5 so in order to ensure it wasn't already fixed in newer versions, as I couldn't specifically find it listed as a fixed bug in 1.6 and 2.0, I cloned the NatTable examples git repository.

In the example EditorExample in the package org.eclipse.nebula.widgets.nattable.examples.examples._110_Editing I changed the code in registerColumnTenComboBox (the City column) and set useCheckbox to true with the combo box.

I saw the same behavior we are seeing in our application, namely that sometimes the value is not changed even when you click on the check box. I've attached a video of what happens. (Sometimes the value is not updated to your selection, sometimes it is. If you deselect the value, then the next selection seems to always work)

Is this a known bug? I searched in the existing bug reports and could not find one for this issue.

Strangely, our Mac users have reported that the editing never works for them, whereas on Windows it does occasionally succeed at changing the value.

Thanks,

Louis
Re: Possible Bug Report for Single Select + Use Checkbox Combobox Cell Editors [message #1840077 is a reply to message #1840042] Tue, 06 April 2021 12:29 Go to previous messageGo to next message
Dirk Fauth is currently offline Dirk FauthFriend
Messages: 2814
Registered: July 2012
Senior Member
Yes it seems that checkboxes and single selection do not work correctly. Looks like nobody ever tried that combination. I suppose the SelectionListener on the dropdownTable in the NatCombo needs to be fixed to handle that scenario correctly
Re: Possible Bug Report for Single Select + Use Checkbox Combobox Cell Editors [message #1840115 is a reply to message #1840077] Wed, 07 April 2021 02:52 Go to previous messageGo to next message
Louis Detweiler is currently offline Louis DetweilerFriend
Messages: 76
Registered: August 2017
Member
Ok I will file a bug report, thanks!
Re: Possible Bug Report for Single Select + Use Checkbox Combobox Cell Editors [message #1840930 is a reply to message #1840115] Thu, 29 April 2021 05:10 Go to previous message
Dirk Fauth is currently offline Dirk FauthFriend
Messages: 29
Registered: March 2020
Junior Member
For someone interested in this topic, this is the ticket:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=572635
Previous Topic:First key press deleted on macOS
Next Topic:ComboBoxCellEditor events on mac
Goto Forum:
  


Current Time: Tue Jun 15 08:05:43 GMT 2021

Powered by FUDForum. Page generated in 0.01808 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top