Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » compile with utils and rt_events
compile with utils and rt_events [message #1839710] Fri, 26 March 2021 10:42 Go to next message
joy woo is currently offline joy wooFriend
Messages: 195
Registered: May 2019
Senior Member
Once i both select utils and rt_events compile forte in
vs 2019 then it throw error C2059 and C2334
Re: compile with utils and rt_events [message #1839716 is a reply to message #1839710] Fri, 26 March 2021 11:38 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 1213
Registered: January 2014
Senior Member
Could you please share the full error message text?
Re: compile with utils and rt_events [message #1839717 is a reply to message #1839716] Fri, 26 March 2021 11:49 Go to previous messageGo to next message
joy woo is currently offline joy wooFriend
Messages: 195
Registered: May 2019
Senior Member

C2059 :"<parameter-list>" ( \forteinit.cpp) FORTE_LITE \forte-incubation_1.13.0\src\modules\utils\GET_AT_INDEX.h 38

C2334 "{"unexpected token´╝Ť \forteinit.cpp) FORTE_LITE \forte-incubation_1.13.0\src\modules\utils\GET_AT_INDEX.h 38
Re: compile with utils and rt_events [message #1839719 is a reply to message #1839717] Fri, 26 March 2021 12:18 Go to previous messageGo to next message
joy woo is currently offline joy wooFriend
Messages: 195
Registered: May 2019
Senior Member
not solved

[Updated on: Fri, 26 March 2021 13:38]

Report message to a moderator

Re: compile with utils and rt_events [message #1839720 is a reply to message #1839719] Fri, 26 March 2021 13:02 Go to previous messageGo to next message
joy woo is currently offline joy wooFriend
Messages: 195
Registered: May 2019
Senior Member
not this problem ecet.h is confilict, if ecet.h not include ,it's ok

[Updated on: Fri, 26 March 2021 13:09]

Report message to a moderator

Re: compile with utils and rt_events [message #1839735 is a reply to message #1839720] Fri, 26 March 2021 18:13 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 1213
Registered: January 2014
Senior Member
I'm sorry I have a hard time following your comments. Can you eleborate a bit more what is working and what not?
Re: compile with utils and rt_events [message #1839744 is a reply to message #1839735] Sat, 27 March 2021 06:57 Go to previous messageGo to next message
Jose Maria Jesus Cabral Lassalle is currently offline Jose Maria Jesus Cabral LassalleFriend
Messages: 4
Registered: January 2021
Junior Member
GET_AT_INDEX.h 38 is

CIEC_ANY &OUT() {

so this is probably related the IN/OUT problem in windows. Not sure the current state of it
Re: compile with utils and rt_events [message #1839780 is a reply to message #1839744] Sun, 28 March 2021 15:22 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 1213
Registered: January 2014
Senior Member
Thanks for pointing that out Jose.

Yes this could again be an IN/OUT problem. The latest version of the exporter addresses this by prefixing variables with "st_". I think now the time has come to do this for all 4diac FORTE code.
Re: compile with utils and rt_events [message #1839781 is a reply to message #1839780] Sun, 28 March 2021 16:14 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 1213
Registered: January 2014
Senior Member
Created a bug report for tracking this issue: https://bugs.eclipse.org/bugs/show_bug.cgi?id=572371

A first fix is here: https://git.eclipse.org/r/c/4diac/org.eclipse.4diac.forte/+/178467

Thanks for testing and feedback. Would love to have this fix in 4diac 1.14.0.
Re: compile with utils and rt_events [message #1840056 is a reply to message #1839781] Tue, 06 April 2021 08:30 Go to previous message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 1213
Registered: January 2014
Senior Member
Thanks to the feedback from Jose and Martin I just merged the fix (https://git.eclipse.org/c/4diac/org.eclipse.4diac.forte.git/commit/?id=e44cad50dd2508406406bbbc86d9575462a9771f). With that your problem should be gone and will be part of 4diac 1.14.0.
Previous Topic:Using 4DIAC in a simulation system
Next Topic:Running forte on 64-bit Raspberry Pi 4 running Ubuntu 20.04.2 LTS
Goto Forum:
  


Current Time: Sun May 16 18:49:50 GMT 2021

Powered by FUDForum. Page generated in 0.02676 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top