Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Restrict Eclipse installer to update only to a version that support JAVA 8(Restrict Eclipse installer to update only to a version that support JAVA 8)
Restrict Eclipse installer to update only to a version that support JAVA 8 [message #1838656] Wed, 03 March 2021 07:32 Go to next message
Valentin Dinca is currently offline Valentin DincaFriend
Messages: 3
Registered: July 2020
Junior Member
Hello.
Is there a way to restrict the Eclipse installer to update to a specific version?
Currently we have JAVA 8 and when I upgraded Eclipse installer now it ask me for a JAVA 11. I attached a picture of the error.
I think with version 1.18.x we didn't have this issue.
We cannot deploy java 11 yet and I was wondering how can I restrict the update only to a version that supports java 8.
Re: Restrict Eclipse installer to update only to a version that support JAVA 8 [message #1838659 is a reply to message #1838656] Wed, 03 March 2021 08:14 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31869
Registered: July 2009
Senior Member
I'm not entirely sure this is related to the installer itself. The latest installers are restributed containing a JRE and will not produce such a message.

I know the IDE was changed to check during the update process if the current JRE is sufficient to be the JRE needed by the update, but you may well have an even older version of the IDE installed that doesn't do such a check.

In the installer itself, you can switch to advanced mode via the menu in the upper right. There you can choose older versions of the product and can see which version of Java that the older version requires. The installer also allows you to choose a JRE to be installed specifically and only for the use by IDE; in that IDE you can still use Java 8 as your JDK/JRE for development purposes via the JRE preferences.


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:I need help with displaying messages.
Next Topic:When I select dark theme, I can't read anything
Goto Forum:
  


Current Time: Sat May 15 18:28:28 GMT 2021

Powered by FUDForum. Page generated in 0.02972 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top