Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Can't resolve SWT in my first SWT application(WindowBuilder SWT import issue)
Can't resolve SWT in my first SWT application [message #1838379] Tue, 23 February 2021 20:18 Go to next message
John Song is currently offline John SongFriend
Messages: 2
Registered: February 2021
Junior Member
I downloaded "Eclipse for RCP and RAP Developers" from the link below:

https://www.eclipse.org/downloads/packages/release/2020-12/r/eclipse-ide-rcp-and-rap-developers

then installed JDK 15 on my PC and windowbuilder from Eclipse MarketPlace.

Afterward try to following an example to test out but it can't resolve SWT package (all red in editor). All the plugin Jars (including swt jar) are in the project library path, but all buttons are greyed out including add libraries button. This does make any sense at all, help is greatly appreciated.


  • Attachment: Capture1.JPG
    (Size: 71.36KB, Downloaded 15 times)
  • Attachment: Capture2.JPG
    (Size: 19.99KB, Downloaded 15 times)
  • Attachment: Capture3.JPG
    (Size: 115.35KB, Downloaded 14 times)
Re: Can't resolve SWT in my first SWT application [message #1838387 is a reply to message #1838379] Tue, 23 February 2021 22:11 Go to previous message
John Song is currently offline John SongFriend
Messages: 2
Registered: February 2021
Junior Member
Well the solution is simply delete modual_info.java auto generated by eclipse
Previous Topic:eclipse proxy settings problem
Next Topic:Do I need a Language Server ?
Goto Forum:
  


Current Time: Sat May 15 18:35:11 GMT 2021

Powered by FUDForum. Page generated in 0.02882 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top