Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Error when updating Eclipse(Unable to read repository which is not configured)
Error when updating Eclipse [message #1837450] Sat, 30 January 2021 07:41 Go to next message
Stepan Novotny is currently offline Stepan NovotnyFriend
Messages: 4
Registered: June 2020
Junior Member
When I click menu "Help / Check for Updates" then up pops an error dialog stating the error "Unable to read repository at http:/updates/content.xml.
URI does not specify a valid host name: http:/updates/content.xml
", but I don't have any such repository configured in "Window / Preferences / Install/Update / Available Software Sites" and the error does not mention the file or registry setting containing this defective URL so I'm unable to delete it. Requesting assistance.

[Updated on: Sat, 30 January 2021 07:48]

Report message to a moderator

Re: Error when updating Eclipse [message #1837600 is a reply to message #1837450] Wed, 03 February 2021 04:53 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31780
Registered: July 2009
Senior Member
If you disable all the Available Software Sites I assume that Updates will not find any updates because there are no sites. Then you can enable one site to see if that's the one that causes the problem.

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Error when updating Eclipse [message #1837603 is a reply to message #1837600] Wed, 03 February 2021 05:29 Go to previous messageGo to next message
Stepan Novotny is currently offline Stepan NovotnyFriend
Messages: 4
Registered: June 2020
Junior Member
Thank you Ed, that was the secret to success. I didn't think of that because the URL displayed was not the erroneous one and it didn't cross my mind that software is as buggy as the people who write it.
Re: Error when updating Eclipse [message #1837612 is a reply to message #1837603] Wed, 03 February 2021 08:00 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31780
Registered: July 2009
Senior Member
Thank you for confirming in case someone else Googles for such a problem and finds this thread. Update sites can be composites that refer to other update sites, and those composites can have bad links in them that could lead to an issue like this, which is confusing because you see a complaint about a URL that you never actually entered directly.

Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Trouble installing
Next Topic:UDT with store procedure use in eclipse java
Goto Forum:
  


Current Time: Sun Mar 07 12:58:13 GMT 2021

Powered by FUDForum. Page generated in 0.03550 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top