Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » install of e(fx)clipse on raspberry pi fails
install of e(fx)clipse on raspberry pi fails [message #1835387] Wed, 02 December 2020 08:31 Go to next message
Andi Riese is currently offline Andi RieseFriend
Messages: 5
Registered: December 2020
Junior Member
I tried to install e/fx)clipse on my Raspberry Pi (3) with marketplace
I get the following message:

Cannot complete the install because one or more required items could not be found.
Software being installed: e(fx)clipse - IDE 3.5.0.201907240300 (org.eclipse.fx.ide.feature.feature.group 3.5.0.201907240300)
Missing requirement: Core (=none UI) components 3.6.0.201907240201 (org.eclipse.fx.core 3.6.0.201907240201) requires 'bundle com.google.guava 21.0.0' but it could not be found
Cannot satisfy dependency:
From: e(fx)clipse - IDE - Basic 3.5.0.201907240300 (org.eclipse.fx.ide.basic.feature.feature.group 3.5.0.201907240300)
To: org.eclipse.fx.core [3.6.0.201907240201]
Cannot satisfy dependency:
From: e(fx)clipse - IDE 3.5.0.201907240300 (org.eclipse.fx.ide.feature.feature.group 3.5.0.201907240300)
To: org.eclipse.fx.ide.basic.feature.feature.group [3.5.0.201907240300]

I have no idea what to do next.
Can anyone help me? Thanks
Andi
Re: install of e(fx)clipse on raspberry pi fails [message #1835401 is a reply to message #1835387] Wed, 02 December 2020 12:54 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31864
Registered: July 2009
Senior Member
That dependency should generally be available in the release train repository, e.g., in

http://download.eclipse.org/releases/2020-09

In Window -> Preferences -> Install /Update -> Available Software is a site like http://download.eclipse.org/releases/<release-version> in the list and enabled?


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: install of e(fx)clipse on raspberry pi fails [message #1835411 is a reply to message #1835387] Wed, 02 December 2020 17:32 Go to previous messageGo to next message
Andi Riese is currently offline Andi RieseFriend
Messages: 5
Registered: December 2020
Junior Member
There is
http://download.eclipse.org/e4/updates/0.12
http://download.eclipse.org/eclipse/releases/juno
http://download.eclipse.org/eclipse/updates/4.2

and all are enabled.

What to do now?
Re: install of e(fx)clipse on raspberry pi fails [message #1835423 is a reply to message #1835411] Thu, 03 December 2020 03:53 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31864
Registered: July 2009
Senior Member
That listing

https://marketplace.eclipse.org/content/efxclipse

doesn't work for such an old version of Eclipse as shown here in the health report for that listing:

https://www.eclipse.org/setups/marketplace/?id=335225

You need a more recent version of Eclipse.


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: install of e(fx)clipse on raspberry pi fails [message #1835462 is a reply to message #1835411] Thu, 03 December 2020 18:46 Go to previous messageGo to next message
Andi Riese is currently offline Andi RieseFriend
Messages: 5
Registered: December 2020
Junior Member
Hi,

I uninstalled eclipse.
I installed again on my Raspberry PI
sudo apt-get install eclipse
Version 3.8.1 was installed.

If I try to install e(fx)clipse (via Marketplace) I get another error:

Cannot complete the install because of a conflicting dependency.
Software being installed: e(fx)clipse - IDE 3.5.0.201907240300 (org.eclipse.fx.ide.feature.feature.group 3.5.0.201907240300)
Software currently installed: Eclipse Plug-in Development Environment 3.8.2.v20130116-091538-7c7wFj0FFt6Zr9bd4AM1JEQMS (org.eclipse.pde.feature.group 3.8.2.v20130116-091538-7c7wFj0FFt6Zr9bd4AM1JEQMS)
Only one of the following can be installed at once:
PDE Core 3.13.100.v20190830-1158 (org.eclipse.pde.core 3.13.100.v20190830-1158)
PDE Core 3.8.1.v20130115-200504 (org.eclipse.pde.core 3.8.1.v20130115-200504)
PDE Core 3.8.0.v20120606-170547 (org.eclipse.pde.core 3.8.0.v20120606-170547)
Cannot satisfy dependency:
From: Xtext based CSS Tooling 3.5.0.201907240300 (org.eclipse.fx.ide.css 3.5.0.201907240300)
To: bundle org.eclipse.pde.core 3.10.0
Cannot satisfy dependency:
From: e(fx)clipse - IDE - CSS 3.5.0.201907240300 (org.eclipse.fx.ide.css.feature.feature.group 3.5.0.201907240300)
To: org.eclipse.fx.ide.css [3.5.0.201907240300]
Cannot satisfy dependency:
From: e(fx)clipse - IDE 3.5.0.201907240300 (org.eclipse.fx.ide.feature.feature.group 3.5.0.201907240300)
To: org.eclipse.fx.ide.css.feature.feature.group [3.5.0.201907240300]
Cannot satisfy dependency:
From: Eclipse Plug-in Development Environment 3.8.2.v20130116-091538-7c7wFj0FFt6Zr9bd4AM1JEQMS (org.eclipse.pde.feature.group 3.8.2.v20130116-091538-7c7wFj0FFt6Zr9bd4AM1JEQMS)
To: org.eclipse.pde.core [3.8.1.v20130115-200504]


Re: install of e(fx)clipse on raspberry pi fails [message #1835463 is a reply to message #1835462] Thu, 03 December 2020 19:06 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31864
Registered: July 2009
Senior Member
Goodness knows what you get when you use "sudo apt-get install eclipse".

Get Eclipse from here:

https://www.eclipse.org/downloads/

If you need some special version of Eclipse (e.g, for aarch64) then get it from here:

https://www.eclipse.org/downloads/packages/release/2020-12/


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: install of e(fx)clipse on raspberry pi fails [message #1836115 is a reply to message #1835463] Mon, 21 December 2020 19:19 Go to previous messageGo to next message
Andi Riese is currently offline Andi RieseFriend
Messages: 5
Registered: December 2020
Junior Member
I'm still working on getting E(fx)clipse...

I followed your advice and went to: https://www.eclipse.org/downloads/

There was only a download -link for windows: eclipse-inst-jre-win64.exe

Finally I found and downloaded 3 files, I don't know which one I need for my Raspberry Pi, probably all 3 are the wrong ones:
a) eclipse-java-2020-12-R-linux-gtk-x86_64.tar.gz
b) eclipse-inst-jre-linux64.tar.gz
c) eclipse-java-2020-12-R-linux-gtk-aarch64.tar.gz

I unpacked the files, but couldn't install eclipse.

I have no idea, what to do.

Re: install of e(fx)clipse on raspberry pi fails [message #1836117 is a reply to message #1836115] Mon, 21 December 2020 22:40 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4044
Registered: July 2009
Senior Member

"c" is the right one, or rather it is Eclipse, not the installer.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: install of e(fx)clipse on raspberry pi fails [message #1836154 is a reply to message #1836117] Tue, 22 December 2020 16:37 Go to previous message
Andi Riese is currently offline Andi RieseFriend
Messages: 5
Registered: December 2020
Junior Member
Right.

I unpacked the file to /home/pi/Downloads/eclipse and
could start eclipse, but it still was eclipse 3.8 .
I wanted to install 4.x .

I found a directory named /usr/share/eclipse and copied all files from /home/pi/Downloads/eclipse to usr/share/eclipse
because I thought, maybe it starts the old version.

Now it runs into an error:
ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
...


Previous Topic:i got a problem
Next Topic:Eclipse 2020-12 can not create workspace in a WSL2 share
Goto Forum:
  


Current Time: Mon May 10 18:41:51 GMT 2021

Powered by FUDForum. Page generated in 0.02859 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top