Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » problems with javac command("javac" is not recognized as an internal or external command. an executable program or batch file)
problems with javac command [message #1835025] Mon, 23 November 2020 15:27 Go to next message
flavio chiarappa is currently offline flavio chiarappaFriend
Messages: 1
Registered: November 2020
Junior Member
hi guys, I recently installed eclipse and i've been trying to run my command-line programs for a couple of days but constantly when I go to enter the command "javac" to compile the source file tells me that it does not recognize the command. I checked the network a little bit and found I had to specify to the system where to find jdk programs. I went here in the advanced system settings, went into the environment variables and specified for both user variables and system variables the path, which in my case is "C:\Program Files (x86)\Java\jre1.8.0_271\bin", however the error persists and I no longer know what to do (and I also tried to specify the path only in environment variables or system variables but nothing changes) I went here in the advanced system settings, went into the environment variables and specified for both user variables and system variables the path, which in my case is "C:Program Files (x86)\Javajre1.8.0_271bin", however the error persists and I no longer know what to do ( I also tried to specify the path only in environment variables or system variables but nothing changes) Someone do you have any ideas or advice? Thank you very much
Re: problems with javac command [message #1835031 is a reply to message #1835025] Mon, 23 November 2020 16:48 Go to previous message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 640
Registered: August 2014
Senior Member
It seems that your Java is the JRE /Java Runtime Environment).

It is not complete enough for compilation. You need the JDK (Java development Kit). Get one compatible with what you have from <https://www.oracle.com/java/technologies/javase/javase-jdk8-downloads.html> and install it, then try again.


--

Tauno Voipio
Previous Topic:'Some eclipse soluntion or I cannot connect to MongoDB server
Next Topic:An error has occurred
Goto Forum:
  


Current Time: Sat May 08 08:03:38 GMT 2021

Powered by FUDForum. Page generated in 0.03147 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top