Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » 4DIAC 1.13.0 IDE(Issues with the UI working)
4DIAC 1.13.0 IDE [message #1834750] Tue, 17 November 2020 11:16 Go to next message
NOJA Power is currently offline NOJA PowerFriend
Messages: 19
Registered: May 2020
Junior Member
Hi,

Just wondering if you could help me with the 1.13.0 IDE, I seem to be having various issues with getting it working.

I downloaded the IDE from the web site since I noticed that it now comes packaged with the correct version of java.
http://www.eclipse.org/downloads/download.php?file=/4diac/releases/1.13/4diac-ide/4diac-ide-incubation_1.13.0-win32.win32.x86_64.zip

Some issues I am having:


  • The monitor/watch for debugging does not work correctly at times
  • Mapping FB to EMB_RES does not work correctly at times
  • The linework does not display correctly at times (close/open IDE usually fixes the issue)
  • The FB code generated from the latest IDE will not compile with C++04 compiler (not a big issue, I can use the old IDE to generate FB changes and we don't need to do this very often)
  • Export fboot window is blank and export is not possible


Here is an example of the export to fboot:
index.php/fa/39318/0/

What am I missing with successfully running the IDE?

Thank you
Re: 4DIAC 1.13.0 IDE [message #1834765 is a reply to message #1834750] Tue, 17 November 2020 13:56 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 1213
Registered: January 2014
Senior Member
Hi,

I'm not happy to hear that. Please see some answers below.

NOJA Power wrote on Tue, 17 November 2020 11:16


  • The monitor/watch for debugging does not work correctly at times


Can you be more specific what is not working. I have not noticed issues here. Is there any output in the .log file.

NOJA Power wrote on Tue, 17 November 2020 11:16


  • Mapping FB to EMB_RES does not work correctly at times


Can you be more specific what is not working. I have not noticed issues here. Is there any output in the .log file.

NOJA Power wrote on Tue, 17 November 2020 11:16


  • The linework does not display correctly at times (close/open IDE usually fixes the issue)


Yes we noticed that. We have introduced an automatic layout algorithm with 1.13.0. You can test that by context menu entry layout the diagrams. Unfortunately we haven't yet managed to align the new layouting with the old routing leading sometimes to not so nice results.

NOJA Power wrote on Tue, 17 November 2020 11:16


  • The FB code generated from the latest IDE will not compile with C++04 compiler (not a big issue, I can use the old IDE to generate FB changes and we don't need to do this very often)


As posted already we are on our way to enhance 4diac FORTE to more modern C++. We try our best to be backwards compatible and therefore happy for feedback.

NOJA Power wrote on Tue, 17 November 2020 11:16


  • Export fboot window is blank and export is not possible


We just recently noticed that we broke this: https://bugs.eclipse.org/bugs/show_bug.cgi?id=568326
Working on it to get it fixed soon.
Re: 4DIAC 1.13.0 IDE [message #1834789 is a reply to message #1834765] Wed, 18 November 2020 01:46 Go to previous messageGo to next message
NOJA Power is currently offline NOJA PowerFriend
Messages: 19
Registered: May 2020
Junior Member
Hi,

In relation to the following items:


  • Mapping FB to EMB_RES does not work correctly at times
  • The linework does not display correctly at times (close/open IDE usually fixes the issue)


I can reliably reproduce the issue as follows:

Unpack the ide zip file. The following message is displayed and I click skip:
index.php/fa/39327/0/

Create some application (this is just an example application, it is not intended to be a useful application). Select some of the function blocks and map to EMB_RES. You can see that only one FB mapped successfully and the linework looks odd.
index.php/fa/39326/0/

Open the EMB_RES and there is the one mapped FB that worked and also a stray function block. The mapped FB can be unmapped. The stray FB needs to be deleted, it can't be unmapped.
index.php/fa/39325/0/

The .log file is attached.

In relation to:


  • The monitor/watch for debugging does not work correctly at times


I can't get past the first issue at the moment. Once I can I'll add some details here.
Re: 4DIAC 1.13.0 IDE [message #1834791 is a reply to message #1834789] Wed, 18 November 2020 04:19 Go to previous messageGo to next message
NOJA Power is currently offline NOJA PowerFriend
Messages: 19
Registered: May 2020
Junior Member
Hi,

I tried mapping FB's to EMB_RES again following different steps and I got a little further.


  • Delete workspace and IDE from previous test
  • Unzip IDE to a short path. I tried C:\4diac-ide\ and this time no error during unzip
  • Create application with a few function blocks and map a few FB's from application to EMB_RES


This time the mapping was successful. Some of the linework shows as dashed when it should be a solid line.
index.php/fa/39328/0/

When I open EMB_RES, there is an exception fault.
index.php/fa/39329/0/

I have also attached the .log file from this test. I'll keep trying.
Re: 4DIAC 1.13.0 IDE [message #1834792 is a reply to message #1834791] Wed, 18 November 2020 05:05 Go to previous messageGo to next message
NOJA Power is currently offline NOJA PowerFriend
Messages: 19
Registered: May 2020
Junior Member
Hi,

Ok, I managed to get past the last issue. This issue is to do with 'monitor' behaviour. These are the steps I took:


  • Continue from last test (previous post)
  • Unmap all
  • ctrl-a in App tab to select all FB's and map to EMB_RES
  • Open EMB_RES, mapping worked
  • Enable disable monitoring on EMB_RES tab a few times, add and remove watch from various FB's
  • Switch to application tab, no watches are available (which are enabled on EMB_RES tab)
  • Enable watches on FB in App tab that already has a watch enabled on EMB_RES tab
  • Switch to EMB_RES tab, the watch on the EMB_RES tab is frozen
  • Clear all watches on all tabs
  • Disable and enable monitor
  • Switch to App tab, enable monitor and watch on FB's
  • Switch to EMB_RES tab to see remnants from App tab


This is the App tab showing the watched. The linework is dashed but should be solid.
index.php/fa/39332/0/

This is the EMB_RES tab showing remnants from App tab.
index.php/fa/39333/0/

Latest .log file attached, looks like it might have a few more exception faults?

If I come across any other examples, I'll post them here.
Re: 4DIAC 1.13.0 IDE [message #1834798 is a reply to message #1834792] Wed, 18 November 2020 07:55 Go to previous message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 1213
Registered: January 2014
Senior Member
Wow. thanks for the detailed feedback. I must say the forum is not a very good place to handle so many different things in one place. But I'll try to answer a view things.

First of all thanks for the log files these help a lot to narrow down your issues.

Regarding the path issue. This is a general Windows problem which we can do very little about it.

One mapping issue has already been fixed and will be available in the upcoming 1.13.1 release. We still have to look into the issue that connections are not drawn correctly all the time. This seems to happen only on Windows machines.

The monitoring thingy will be a bigger thing to look into. There we have some major changes in the internal data structures that have to be rethought.

Previous Topic:Timer function block accuracy
Next Topic:Creating an external event handler
Goto Forum:
  


Current Time: Sun May 16 16:43:22 GMT 2021

Powered by FUDForum. Page generated in 0.02454 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top