Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Error updating to Java 15(Not sure what I am missing, but errors requiring that I update my version of Java exist in my project, but once I updated to Java 15 it's still not working)
Error updating to Java 15 [message #1834459] Tue, 10 November 2020 16:45 Go to next message
Katie Carroll is currently offline Katie CarrollFriend
Messages: 2
Registered: November 2020
Junior Member
Hello,

I am picking up a project that I left off a few months ago with a team who seem to have included some syntax that is only available in Java 14 onwards (see below).

I have downloaded JDK 15 and set my JRE System Library in eclipse to this path. However, I'm still running into the below errors.

How can I ensure that my Eclipse is using the latest version of Java so that these errors are eliminated?

Thank you for your help!
Re: Error updating to Java 15 [message #1834476 is a reply to message #1834459] Wed, 11 November 2020 02:36 Go to previous messageGo to next message
Manoj Palat is currently offline Manoj PalatFriend
Messages: 18
Registered: October 2014
Junior Member
Hi Katie,
Looks like the compliance is not set to Java 14 - please go to preferences and filter with compliance and check whether you have 14 in your compliance - the Java compiler in Eclipse uses that option to decide the level .

If you still have an issue, please file a bug against JDT.Core here: https://bugs.eclipse.org/bugs/enter_bug.cgi?product=JDT

Regards,
Manoj


Manoj N Palat
Eclipse Java Development Tools (JDT).
Re: Error updating to Java 15 [message #1834497 is a reply to message #1834476] Wed, 11 November 2020 13:37 Go to previous message
Katie Carroll is currently offline Katie CarrollFriend
Messages: 2
Registered: November 2020
Junior Member
Hi Manoj,
That worked! Thank you so much for your help.
Kind regards,
Katie
Previous Topic:Error in Java
Next Topic:Eclipse 2020-09 (for Java) XML Editor shows new errors which were not there before. What to do?
Goto Forum:
  


Current Time: Sun Apr 11 05:20:35 GMT 2021

Powered by FUDForum. Page generated in 0.02640 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top