Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse needs newer Java version than is available(Eclipse needs newer Java version than is available)
Eclipse needs newer Java version than is available [message #1832375] Thu, 17 September 2020 09:27 Go to next message
Helmut Lüdders is currently offline Helmut LüddersFriend
Messages: 2
Registered: September 2020
Junior Member
After updating Eclipse today I get the following error when starting Eclipse:
Version 1.8.0_261 of the JVM is not suitable for this product. Version: 11 or greater is required.

But the newest Java version that is available on java.com is version 8, there is no version 11.

What must I do to start Eclipse again?

In case it's relevant, I'm on Windows 10 and this is my exact Java version:
java version "1.8.0_261"
Java(TM) SE Runtime Environment (build 1.8.0_261-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.261-b12, mixed mode)
Re: Eclipse needs newer Java version than is available [message #1832395 is a reply to message #1832375] Thu, 17 September 2020 11:57 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 616
Registered: August 2014
Senior Member
Try this: https://www.oracle.com/java/technologies/javase-jdk11-downloads.html


--

Tauno Voipio
Re: Eclipse needs newer Java version than is available [message #1832401 is a reply to message #1832395] Thu, 17 September 2020 13:20 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31702
Registered: July 2009
Senior Member
There are also these:

https://jdk.java.net/
https://adoptopenjdk.net/


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Eclipse needs newer Java version than is available [message #1832485 is a reply to message #1832401] Fri, 18 September 2020 16:57 Go to previous message
Helmut Lüdders is currently offline Helmut LüddersFriend
Messages: 2
Registered: September 2020
Junior Member
Thanks. Installing the OpenJDK binaries solved the problem.
Previous Topic:Installation
Next Topic:VPMS Troubleshooting
Goto Forum:
  


Current Time: Mon Jan 18 05:05:44 GMT 2021

Powered by FUDForum. Page generated in 0.02781 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top