Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Polarsys » M2Doc » Problem with extracting interfaces from CII diagram
Problem with extracting interfaces from CII diagram [message #1832319] Wed, 16 September 2020 09:37 Go to next message
hassene dhaou is currently offline hassene dhaouFriend
Messages: 2
Registered: July 2020
Junior Member
Hello,

I'm using M2DOC to generate documentation from my capella model and I've encountered an error when trying to extract interfaces from a CII "Contextual Internal Interface" diagram.

I'm using the following M2DOC command:

{m:let contenuDiagram = '[CII] Bilan des interfaces KPVA '. representationByName().eAllContents(viewpoint::DRepresentationElement).semanticElements}
{m:for interface|contenuDiagram->filter(cs::Interface)}
...
{endlet}
{endfor}

At the generation, I get the following error:
"Couldn't find the 'aqlFeatureAccess(org.eclipse.acceleo.query.runtime.impl.Nothing,java.lang.String)' service" under the "let" command (as mentioned above)

I should note that the command "self.eAllContents(viewpoint::DRepresentationElement).semanticElements->filter(cs::Interface)" works correctly when plugged in the capella interpreter (self = clicking on the back of the CII diagram) and I get the interfaces in the CII diagram as an interpreter result.

Is this problem caused by missing nsURI packages (I already added the *capella and *sirius packages in my template properties) or is it a semantic problem?


Note:
I'm using capella 1.4.0 with M2DOC version 3.0.0
The same command works correctly for a LAB diagram with M2DOC ( for example with filter (la::LogicalComponent)).
Re: Problem with extracting interfaces from CII diagram [message #1832330 is a reply to message #1832319] Wed, 16 September 2020 12:50 Go to previous messageGo to next message
Yvan Lussaud is currently offline Yvan LussaudFriend
Messages: 63
Registered: July 2009
Member
I think '[CII] Bilan des interfaces KPVA '. representationByName().eAllContents(viewpoint::DRepresentationElement) doesn't return anything which cause the error when accessing .semanticElements.
First check the trailing space in the representation name. Maybe it's from the copy/past here or in your template. If it's not the trailing space you should try the expression with out the .semanticElements and outside of a let to see if you can get more information in the error message.
And yes a missing nsURI whould have been a good candidate.
Re: Problem with extracting interfaces from CII diagram [message #1832481 is a reply to message #1832330] Fri, 18 September 2020 15:39 Go to previous message
hassene dhaou is currently offline hassene dhaouFriend
Messages: 2
Registered: July 2020
Junior Member
Hello Yvan,

Thank you for your reply.
As you mentioned, I deleted the extra blank spaces at the end of the diagram name, between the (' ') signs, and before the representationByName command.
The problem was solved and I was able to display the interfaces in my generated document.
Previous Topic:Unable to find source name
Next Topic:how to edit "Allocating Actor/Component (computed)" with M2DOC
Goto Forum:
  


Current Time: Tue Nov 29 11:39:01 GMT 2022

Powered by FUDForum. Page generated in 0.02773 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top