Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Updating Eclipse ... still bugged after 1X years?
Updating Eclipse ... still bugged after 1X years? [message #1831736] Thu, 27 August 2020 16:24 Go to next message
Maro Nary is currently offline Maro NaryFriend
Messages: 3
Registered: August 2020
Junior Member
I imagine many know this error - I want to update Eclipse

Help -> Check for Updates -> Wait for scanning .. -> Next -> Finish -> Problem Occurred

index.php/fa/38826/0/

I just installed the newest Eclipse CDT 2020-06 a few weeks ago, waiting for some update to appear so I could try it once again. It is a completely clean install, though with on imported workspace of the previous version. However, the same error occurs if I switch to a new, completely clean workspace. The only way for me to update is still downloading a new installer, installing a clean updated version, and importing my previous workspace - hoping that it doesn't break.

I have been stuck with this error since I first started using Eclipse over 10 years ago. I am currently on Windows 10, but over the years I was using Win 7 and older versions I don't remember, and also recent versions of Ubuntu (Linux) - even there, I get the same error.

The error was known to exist a long time ago - with some workarounds posted on stackoverflow ... the same answers/workarounds still seem to be the most up-to-date information regarding this error - and none of them have ever worked for me. Here my (clean/unchanged) update sites from my few-week-old CDT 2020-06 install:

index.php/fa/38827/0/

* Removing sites and readding does nothing, the same error occurs
* Adding a trailing "/" does not help, instead, Eclipse removes the site from the list by itself - the same error occurs
* Unchecking "Contact all update sites during install to find required software" in "Install New Software..." does nothing, the same error occurs

I must be doing something wrong .. an essential feature like updating surely cannot be bugged for over 10 years. Is there really no fix after such a long time?
  • Attachment: eue2.jpg
    (Size: 92.45KB, Downloaded 278 times)
  • Attachment: eue1.jpg
    (Size: 122.49KB, Downloaded 282 times)

[Updated on: Thu, 27 August 2020 16:25]

Report message to a moderator

Re: Updating Eclipse ... still bugged after 1X years? [message #1831745 is a reply to message #1831736] Thu, 27 August 2020 21:24 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4267
Registered: July 2009
Senior Member

You seem to have http://download.eclipse.org/oomph/updates, which is where I'd expect those particular bundles and features to come from, Disabled. Try Enabling it.

Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Thu, 27 August 2020 21:25]

Report message to a moderator

Re: Updating Eclipse ... still bugged after 1X years? [message #1831746 is a reply to message #1831745] Thu, 27 August 2020 22:32 Go to previous messageGo to next message
Maro Nary is currently offline Maro NaryFriend
Messages: 3
Registered: August 2020
Junior Member
I enabled it and tried again. Still getting the same error. Also same error if I also disable Oomph Latest Milestone at the same time.. =/
Re: Updating Eclipse ... still bugged after 1X years? [message #1847955 is a reply to message #1831746] Mon, 15 November 2021 09:17 Go to previous messageGo to next message
Lucio Menci is currently offline Lucio MenciFriend
Messages: 7
Registered: June 2017
Junior Member
I have the same issue, but I have it for the first time. I changed my PC recently, in the previous one the updates were good, now I have an error very longer than yours. Have you found some solution?

This is my error...
index.php/fa/41318/0/
  • Attachment: Snap1.png
    (Size: 458.48KB, Downloaded 125 times)

[Updated on: Mon, 15 November 2021 09:18]

Report message to a moderator

Re: Updating Eclipse ... still bugged after 1X years? [message #1848112 is a reply to message #1847955] Sat, 20 November 2021 19:21 Go to previous message
apollos dada is currently offline apollos dadaFriend
Messages: 5
Registered: April 2021
Junior Member
Hi, did you manage to fix the problem?
Previous Topic:Indexer stops too many errors
Next Topic:mingw application variables livewatch during debug on windows
Goto Forum:
  


Current Time: Thu Oct 06 18:28:40 GMT 2022

Powered by FUDForum. Page generated in 0.02080 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top