Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Is Eclipse 2020-06 compatible with Adopt OpenJDK 11(Unable to make it work reliably - frequent Cannot find the class file for java.lang.Object errors.)
Is Eclipse 2020-06 compatible with Adopt OpenJDK 11 [message #1830926] Thu, 06 August 2020 19:10 Go to next message
Bruno Melloni is currently offline Bruno MelloniFriend
Messages: 6
Registered: August 2020
Junior Member
I have been using Eclipse for many years. Today I decided to bite the bullet and migrate from Java8 to the Adopt OpenJDK 11 (LTE) version and Eclipse for JEE 2020-06.

The biggest problem is that I keep getting the "Cannot find the class file for java.lang.Object" error so frequently that it makes it unusable. I already did clean builds, restarted with eclipse -clean, and the one solution that seems to work temporarily is to remove and re-add the JDK in the windows/preferences.

This is frustrating because I never had these kinds of problems before. I am probably going to try other IDEs and other JDKs.


But before doing that I figured I'd ask here if there are known incompatibilities or advice to how to make Eclipse work reliably with a stable version of any Java 11 JDK (that JDK would also need to work reliably with Tomcat).
Re: Is Eclipse 2020-06 compatible with Adopt OpenJDK 11 [message #1830930 is a reply to message #1830926] Thu, 06 August 2020 22:24 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3881
Registered: July 2009
Senior Member

Yes. It's what I test that package with. That can happen if they somehow aren't referring to a valid entry
on the Installed JREs preference page. So pick one of your projects and dig into how its Java Build Path
is set up. If you're referring to a JRE using the name it's been given in your preferences, I'd suggest
changing it to either the "default" or an Execution Environment-based value.


Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Thu, 06 August 2020 22:25]

Report message to a moderator

Re: Is Eclipse 2020-06 compatible with Adopt OpenJDK 11 [message #1830982 is a reply to message #1830930] Fri, 07 August 2020 17:14 Go to previous message
Bruno Melloni is currently offline Bruno MelloniFriend
Messages: 6
Registered: August 2020
Junior Member
SOLVED:

Turns out that the cause was quite unexpected. Even though JDK 11 was first in the PATH and was in JAVA_HOME environment variables, there was some old JAVA classpath trash left over from before that Eclipse somehow picked up on. Once I removed ever trace of Java 8 pieces (that shouldn't have been seen anyway) the issue went away.
Previous Topic:junit plugin update within Eclipse IDE 2019.3
Next Topic:Eclipse IDE for Enterprise Java Developers silent install and configure
Goto Forum:
  


Current Time: Wed Oct 28 03:56:35 GMT 2020

Powered by FUDForum. Page generated in 0.02065 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top