Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse IDE strange behavior
Eclipse IDE strange behavior [message #1829626] Tue, 07 July 2020 21:22 Go to next message
Paul * is currently offline Paul *Friend
Messages: 3
Registered: July 2020
Junior Member
Hallo.

I'm using eclipse IDE for Java Developers for a couple months now. But since a couple days, I get really strange behavior. This is what I get.

- When I startup eclipse, everything is normal. But when I export my project, the font in the package explorer changes. It also get's bigger, so some letters aren't readable. This is also the case for the settings, but not the settings navigation.
- Sometimes, the completion suggestions just stop working, for no reason at all. In the left-bottom of eclipse, I see No completions available. No matter what I change in the settings, the completions won't come back. When I restart eclipse, I have completions working again.
- Sometimes, I can't export a project. When I right-click on my project, and then click Export..., nothing happens. No window, no export, nothing. I need to restart eclipse to get it back working again.
- The completions menu is way to big, and sometimes takes up the whole screen, other times only a small vertical bar, from the top to the bottom, other times a horizontal bar, from right to left. It's very inconsistent.

I tried everything I could think of. I switched workspaces, deleted all eclipse data (.eclipse and %localappdata%), and I tried these versions of eclipse.
- 2020-6
- 2020-3
- 2019-12

This is getting really annoying. It gets to a point that I want to switch to another IDE, but no other IDE works good enough for me, except for eclipse, before all the issues.

I'm using windows 10.

Does someone know what's going on and how I can fix it? Please don't say that I have to wait two months for 2020-9...
Re: Eclipse IDE strange behavior [message #1829632 is a reply to message #1829626] Wed, 08 July 2020 04:08 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31608
Registered: July 2009
Senior Member
There were some comments on this thread about recent versions of Windows doing strange things with fonts:

https://www.eclipse.org/forums/index.php/mv/msg/1104362/1829585/#msg_1829585

As for the failures, hopefully there are some clues (stack traces) in the Error Log view. Press the magnifying glass icon in the upper right and type "Error" to open that view.


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Eclipse IDE strange behavior [message #1829642 is a reply to message #1829632] Wed, 08 July 2020 08:33 Go to previous messageGo to next message
Paul * is currently offline Paul *Friend
Messages: 3
Registered: July 2020
Junior Member
I turned Use mixed fonts and colors for labels off and restarted eclipse, but the font in the package explorer still changes after I export my project.

This is the error for the completions not working.
eclipse.buildId=4.14.0.I20191210-0610
java.version=1.8.0_251
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=nl_NL
Framework arguments:  -product org.eclipse.epp.package.java.product
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.java.product

org.eclipse.ui
Error
Wed Jul 08 10:31:04 CEST 2020
Unhandled event loop exception

java.lang.IllegalArgumentException: Argument not valid
	at org.eclipse.swt.SWT.error(SWT.java:4701)
	at org.eclipse.swt.SWT.error(SWT.java:4635)
	at org.eclipse.swt.SWT.error(SWT.java:4606)
	at org.eclipse.swt.graphics.FontData.setHeight(FontData.java:475)
	at org.eclipse.jface.dialogs.PopupDialog.applyFonts(PopupDialog.java:1442)
	at org.eclipse.jface.dialogs.PopupDialog.createContents(PopupDialog.java:696)
	at org.eclipse.jface.window.Window.create(Window.java:431)
	at org.eclipse.ui.internal.quickaccess.QuickAccessDialog.lambda$0(QuickAccessDialog.java:227)
	at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:72)
	at org.eclipse.ui.internal.quickaccess.QuickAccessDialog.<init>(QuickAccessDialog.java:117)
	at org.eclipse.ui.internal.quickaccess.SearchField.activate(SearchField.java:223)
	at org.eclipse.ui.internal.quickaccess.SearchField.lambda$1(SearchField.java:97)
	at org.eclipse.swt.events.SelectionListener$1.widgetSelected(SelectionListener.java:84)
	at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:252)
	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:89)
	at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4175)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1057)
	at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3988)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3587)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1160)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1049)
	at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:155)
	at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:660)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:559)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:154)
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:150)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:137)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:107)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:401)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:657)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:594)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
Re: Eclipse IDE strange behavior [message #1829668 is a reply to message #1829642] Wed, 08 July 2020 12:48 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3904
Registered: July 2009
Senior Member

Is it always triggered by Exporting a project? Is there a release far enough back where that doesn't happen, then?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Eclipse IDE strange behavior [message #1829685 is a reply to message #1829668] Wed, 08 July 2020 20:55 Go to previous message
Paul * is currently offline Paul *Friend
Messages: 3
Registered: July 2020
Junior Member
I don't know if it's only triggered when I export a project. I do know that it's really inconsistent. One time I get it really fast, other times after half an hour.
Like I sad earlier, I never had problems before. The problems just appeared, out of nothing. I didn't update eclipse or updated windows or something like that.
Previous Topic:Crashed after Installation of EclipseWebTool Platform
Next Topic:Windows 10 Java 64
Goto Forum:
  


Current Time: Thu Nov 26 23:09:20 GMT 2020

Powered by FUDForum. Page generated in 0.03514 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top