Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Garbled characters in Eclipse/Spring Tool Suite UI(Garbled characters in Eclipse/Spring Tool Suite UI)
Garbled characters in Eclipse/Spring Tool Suite UI [message #1829548] Mon, 06 July 2020 17:40 Go to next message
Alfred Wan is currently offline Alfred WanFriend
Messages: 7
Registered: July 2020
Junior Member
Garbled characters in Eclipse/Spring Tool Suite UI. Java class names, package names, class names, etc. All look garbled. I've tried to change preferences->Workspace->General Text file encoding (UTF, Cp1252, etc.) but nothing fixes the garbled names in the User Interface (Eclipse/STS itself). Anyone please?
Re: Garbled characters in Eclipse/Spring Tool Suite UI [message #1829555 is a reply to message #1829548] Mon, 06 July 2020 18:45 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6880
Registered: July 2009
Senior Member
Hi

You don't say what version of Eclipse you are using.

I found one problem in the latest version whereby the Windows Classic Theme was obsoleted and folded back to something less satisfactory. That 'bug' was fixed by folding to Windows Theme.

With two users reporting a problem and both their names perhaps indicating an East Asian background, it could be that some other 'redundant' preference has also been trimmed that only affects users who also use Chinese or similar character sets.

Window->Preferences->General->Appearance->Colors and Fonts is where you want to play to see if you can change what you see. My guess is that you are using a font that is no longer available from where it came from, or that a user-friendly Eclipse font chooser is going out to match what the OS provides and that that algorithm is now picking a Chinese font.

Regards

Ed Willink

Re: Garbled characters in Eclipse/Spring Tool Suite UI [message #1829563 is a reply to message #1829555] Mon, 06 July 2020 21:24 Go to previous messageGo to next message
Alfred Wan is currently offline Alfred WanFriend
Messages: 7
Registered: July 2020
Junior Member
Hi, thanks for the reply. I'm using STS 4.4.7 and installed the latest Eclipse today (JEE developers edition 06-2020). I also tried previous installations of STS (4.4.6 and back) with the same result. It may have something to do with the Windows installation, I already rolled back to a previous insider preview because of problems, but that option is no longer available anymore (lost backups). I'm having build 20161 prerelease 200627-1754 running.
Re: Garbled characters in Eclipse/Spring Tool Suite UI [message #1829584 is a reply to message #1829555] Tue, 07 July 2020 10:12 Go to previous messageGo to next message
Alfred Wan is currently offline Alfred WanFriend
Messages: 7
Registered: July 2020
Junior Member
I looked at your suggestion again, and I found that Unchecking "Use mixed fonts and colors for labels" in Window-Preferences->Gereral->Apearance makes the package -, class names, etc. readable. It isn't what it used to be and I guess what it's supposed to be but it's workable again. Thanks!
Re: Garbled characters in Eclipse/Spring Tool Suite UI [message #1829599 is a reply to message #1829584] Tue, 07 July 2020 13:09 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6880
Registered: July 2009
Senior Member
Hi

Please raise a Bugzilla since I suspect that you are just the first of many who will be caught out by the OS / Eclipse / ? ... change that does not affect me.

Regards

Ed Willink
Re: Garbled characters in Eclipse/Spring Tool Suite UI [message #1829620 is a reply to message #1829599] Tue, 07 July 2020 17:02 Go to previous messageGo to next message
sorin cristescu is currently offline sorin cristescuFriend
Messages: 4
Registered: July 2020
Junior Member
It happens on Windows 10 build 20161 (preview version).
Re: Garbled characters in Eclipse/Spring Tool Suite UI [message #1829622 is a reply to message #1829599] Tue, 07 July 2020 17:46 Go to previous messageGo to next message
Alfred Wan is currently offline Alfred WanFriend
Messages: 7
Registered: July 2020
Junior Member
Hi,

I found one post that reports a similar problem but no further background/context about it.

What do you mean by "raise a Bugzilla"?
Re: Garbled characters in Eclipse/Spring Tool Suite UI [message #1829641 is a reply to message #1829622] Wed, 08 July 2020 08:01 Go to previous messageGo to next message
sorin cristescu is currently offline sorin cristescuFriend
Messages: 4
Registered: July 2020
Junior Member
I opened the bug: https://bugs.eclipse.org/bugs/show_bug.cgi?id=565025

I think in the last preview build 20161 of the Windows 10, they removed a font, and all the eclipse versions, plus tortoise svn, do have that hardcoded somewhere.

Thanks,
/S
Re: Garbled characters in Eclipse/Spring Tool Suite UI [message #1829700 is a reply to message #1829584] Thu, 09 July 2020 07:55 Go to previous message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6880
Registered: July 2009
Senior Member
Hi

Alfred Wan wrote on Tue, 07 July 2020 06:12
I found that Unchecking "Use mixed fonts and colors for labels" in Window-Preferences->Gereral->Apearance makes the package -, class names, etc. readable.


As commented on https://bugs.eclipse.org/bugs/show_bug.cgi?id=565025, it would be good to have a screen shot of this dialog in its bad state so that the developers can see what bad choice has managed to get into Eclipse. Please attach a screen shot to the Bugzilla.

Regards

Ed Willink
Previous Topic:resource mapping in glassfish-ejb-jar.xml
Next Topic:"Run Configuration" naming
Goto Forum:
  


Current Time: Sat Oct 31 13:13:06 GMT 2020

Powered by FUDForum. Page generated in 0.01770 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top