Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » What are the minimum requirements of SWT (OSX)
What are the minimum requirements of SWT (OSX) [message #1829102] Thu, 25 June 2020 07:58 Go to next message
Johan Compagner is currently offline Johan CompagnerFriend
Messages: 13
Registered: August 2014
Junior Member
A customer is trying our eclipse on an older OSX version (10.8.5)
but he gets:

Application error!STACK 1org.eclipse.swt.SWTError: Not implemented at org.eclipse.swt.SWT.error(SWT.java:4746) at org.eclipse.swt.SWT.error(SWT.java:4635) at org.eclipse.swt.SWT.error(SWT.java:4606) at org.eclipse.swt.widgets.Display.error(Display.java:1112) at org.eclipse.swt.widgets.Display.createDisplay(Display.java:846) at org.eclipse.swt.widgets.Display.create(Display.java:837) at org.eclipse.swt.graphics.Device.<init>(Device.java:132) at org.eclipse.swt.widgets.Display.<init>(Display.java:736) at org.eclipse.swt.widgets.Display.<init>(Display.java:727) at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:778) at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:166) at org.eclipse.ui.internal.ide.application.IDEApplication.createDisplay(IDEApplication.java:180) at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123) at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:137) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:107) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:401) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:657) at org.eclipse.equinox.launcher.Main.basicRun(Main.java:594) at org.eclipse.equinox.launcher.Main.run(Main.java:1465)

googling this doesn't give me much (or very old results)
Also it doesn't say what is not implemented..

So i wonder what are the minimum requirements for SWT on OSX?
I guess it must be 64 bit, but as far as i know 10.8 is 64 bits and it seems to start in 64 bit mode.
Re: What are the minimum requirements of SWT (OSX) [message #1829115 is a reply to message #1829102] Thu, 25 June 2020 11:18 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 877
Registered: January 2012
Senior Member

Wow 10.8 was released 7 years ago and received its last update 4 years ago.

You didn't say what version of the platform you ship on. The list of supported operating systems is listed in each release's release notes, which links to the release plan's "Target Environments" section of the Eclipse project plan. For example, here are the release notes and plan for 4.13:

https://www.eclipse.org/eclipse/development/readme_eclipse_4.13.php
https://www.eclipse.org/projects/project-plan.php?planurl=http://www.eclipse.org/eclipse/development/plans/eclipse_project_plan_4_13.xml#target_environments
Re: What are the minimum requirements of SWT (OSX) [message #1829117 is a reply to message #1829115] Thu, 25 June 2020 11:39 Go to previous message
Johan Compagner is currently offline Johan CompagnerFriend
Messages: 13
Registered: August 2014
Junior Member
right that was what i was searching for a bit
I know it is old, but i just wanted to have some documentation where i could find such a thing.

But it is very hard to find for example:

https://www.eclipse.org/downloads/

go from there.. where is the OS requirement?

the only thing you can find if you really click around from there is:

https://wiki.eclipse.org/Eclipse/Installation#Eclipse_4.15_.282020-03.29

but that only mentions that java 8 is required.

Problem is that SWT has a lot more stuff (windows mostly works) but it seems that mac and i guess also Linux (gtk version?) are also a big factor.
Previous Topic:Code signature error: could not load SWT library in OS X Catalina
Next Topic:ARM port
Goto Forum:
  


Current Time: Fri Apr 16 15:37:08 GMT 2021

Powered by FUDForum. Page generated in 0.01493 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top