Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Keybinding conflicts involving jface plug-in(After moving to latest version of Eclipse I get "keybinding conflicts" involving plugin I am not using (?))
Keybinding conflicts involving jface plug-in [message #1828892] Sun, 21 June 2020 15:21 Go to next message
Paul Morrison is currently offline Paul MorrisonFriend
Messages: 5
Registered: July 2009
Junior Member
I have just moved most of my projects to a new version of Eclipse (Version: 2020-06 (4.16.0) ), starting with an empty workspace/.metadata file. After transferring a few projects, I am seeing "Keybinding conflicts occurred", and the plugin involved is shown as org.eclipse.jface . I didn't ask for this plugin - but some of my projects use other suppliers' jar files - could one of them be pulling it in? And (whether or not this is true) what can I do about it?

TIA
Re: Keybinding conflicts involving jface plug-in [message #1828899 is a reply to message #1828892] Sun, 21 June 2020 17:46 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31230
Registered: July 2009
Senior Member
JFace logs the issues, but it doesn't cause them. Any plugin can register a key binding and if more registers for the same key combination (and context), then JFace will log about it because of course only one of them can actually work. Perhaps if you shared the actual logged messages it will be more clear what is contributing the conflicting registrations.
Re: Keybinding conflicts involving jface plug-in [message #1828994 is a reply to message #1828899] Tue, 23 June 2020 17:43 Go to previous messageGo to next message
Paul Morrison is currently offline Paul MorrisonFriend
Messages: 5
Registered: July 2009
Junior Member
Hi Ed, Thanks for getting back to me! I am appending my current problem log...

IIUC JFace is connected with SVT - if I don't use SVT in my app, should it still show in my problem log?

Thanks in advance,

Paul M.
Re: Keybinding conflicts involving jface plug-in [message #1829019 is a reply to message #1828994] Wed, 24 June 2020 05:08 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31230
Registered: July 2009
Senior Member
So it looks like org.eclipse.jdt.ui.navigate.open.type and org.eclipse.lsp4e.symbolinworkspace both register CTRL+SHIFT+T. JDT has always used CTRL+SHIFT+T so I'm not sure what the "lsp4e" folks were thinking to use that as well... Of course the general problem is that depending on what combination of things are installed one can't know what might have been used already by something else. These two things are both on the release train though, so they might have noticed if they'd installed both JDT and lspe together...

You ask about your app, but isn't this log from the running IDE? The IDE itself of course uses JFace .
Re: Keybinding conflicts involving jface plug-in [message #1829066 is a reply to message #1829019] Wed, 24 June 2020 13:54 Go to previous messageGo to next message
Juan Soria is currently offline Juan SoriaFriend
Messages: 1
Registered: June 2020
Junior Member
I have just downloaded the same Eclipse version as Paul's and started with a brand new workspace. No projects, nothing at all. The log goes just like his:

!SESSION 2020-06-24 14:44:21.028 -----------------------------------------------
eclipse.buildId=4.16.0.I20200604-0540
java.version=1.8.0_251
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=pt_BR
Framework arguments: -product org.eclipse.epp.package.jee.product
Command-line arguments: -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.jee.product

!ENTRY org.eclipse.jface 2 0 2020-06-24 14:44:30.891
!MESSAGE Keybinding conflicts occurred. They may interfere with normal accelerator operation.
!SUBENTRY 1 org.eclipse.jface 2 0 2020-06-24 14:44:30.891
!MESSAGE A conflict occurred for CTRL+SHIFT+T:
Binding(CTRL+SHIFT+T,
ParameterizedCommand(Command(org.eclipse.jdt.ui.navigate.open.type,Open Type,
Open a type in a Java editor,
Category(org.eclipse.ui.category.navigate,Navigate,null,true),
org.eclipse.ui.internal.WorkbenchHandlerServiceHandler@acea29e,
,,true),null),
org.eclipse.ui.defaultAcceleratorConfiguration,
org.eclipse.ui.contexts.window,,,system)
Binding(CTRL+SHIFT+T,
ParameterizedCommand(Command(org.eclipse.lsp4e.symbolinworkspace,Go to Symbol in Workspace,
,
Category(org.eclipse.lsp4e.category,Language Servers,null,true),
org.eclipse.ui.internal.WorkbenchHandlerServiceHandler@772bc4c9,
,,true),null),
org.eclipse.ui.defaultAcceleratorConfiguration,
org.eclipse.ui.contexts.window,,,system)

I have already tried to unbind one of those keys. That didn't go well and the binding is lost.

So... should this be reported as a bug? Is there any way for me to make a pull request or contribute in some way to solve this?
Re: Keybinding conflicts involving jface plug-in [message #1829069 is a reply to message #1829066] Wed, 24 June 2020 15:22 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3749
Registered: July 2009
Senior Member

As Ed pointed out, this isn't a new problem. I'd be tempted to report it against both as their keybindings are "in Windows" and not limited to their editors, views, and perspectives. https://bugs.eclipse.org/bugs/show_bug.cgi?id=135572#c3 indicates that JDT can disable theirs on certain perspectives, but the default perspective of the Enterprise Java package, the Java EE perspectives, would really be expected to have the Java keybindings work.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Keybinding conflicts involving jface plug-in [message #1829075 is a reply to message #1829019] Wed, 24 June 2020 18:20 Go to previous message
Paul Morrison is currently offline Paul MorrisonFriend
Messages: 5
Registered: July 2009
Junior Member
Many thanks, all of you!

Ed, I guess I had never seen IDE-related (?) messages before in my problem log, so I was just assuming that this message had to do with my application settings! Nice to know that, this time, it wasn't my fault!

All the best, and stay safe, everyone!

Paul

PS I am not getting any notifications about your responses, even though I have the box checked... ???
Previous Topic:Eclipse 2020-06 - Decoration Calculation has encountered a problem
Next Topic:Can't get classes in Referenced Libraries recognized.
Goto Forum:
  


Current Time: Sun Jul 05 11:54:05 GMT 2020

Powered by FUDForum. Page generated in 0.03334 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top