Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Is TLS certificate on marketplace site used by 2020-06 self-signed?
Is TLS certificate on marketplace site used by 2020-06 self-signed? [message #1828799] Fri, 19 June 2020 00:24 Go to next message
David M. Karr is currently offline David M. KarrFriend
Messages: 700
Registered: July 2009
Senior Member
Before today, I was using Eclipse 2020-03.

Our firewall blocks TLS connections to servers that use self-signed certificates. There are at least two Eclipse plugins that I use that have update sites using self-signed certificates. When I want to check for updates to those plugins, I have to disconnect from VPN, change the Eclipse Network Connections settings, and then update.

Today I installed 2020-06.

Now, when I even attempt to bring up the marketplace client dialog, I get TLS connection errors. I would have to assume that 2020-06 is connecting to a different marketplace site than 2020-03, but that seems a little odd.

I will attempt to disconnect from VPN and see whether that fixes the marketplace client.

I confirm that it does.

[Updated on: Fri, 19 June 2020 05:29]

Report message to a moderator

Re: Is TLS certificate on marketplace site used by 2020-06 self-signed? [message #1828810 is a reply to message #1828799] Fri, 19 June 2020 06:32 Go to previous messageGo to next message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 181
Registered: April 2012
Senior Member
I created a bug report on the Eclipse infrastructure for you:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=564452
Re: Is TLS certificate on marketplace site used by 2020-06 self-signed? [message #1828816 is a reply to message #1828810] Fri, 19 June 2020 07:15 Go to previous messageGo to next message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 181
Registered: April 2012
Senior Member
As indicated in the bug report, it might depend on your JRE version. Which JRE and version are you using?
Re: Is TLS certificate on marketplace site used by 2020-06 self-signed? [message #1828837 is a reply to message #1828816] Fri, 19 June 2020 15:47 Go to previous messageGo to next message
David M. Karr is currently offline David M. KarrFriend
Messages: 700
Registered: July 2009
Senior Member
This instance is running with jdk-12.0.1 , but I also just upgraded to JDK 14 and JDK 14.0.1 (just downloaded a moment ago), and they all still have the problem.

[Updated on: Fri, 19 June 2020 16:25]

Report message to a moderator

Re: Is TLS certificate on marketplace site used by 2020-06 self-signed? [message #1828852 is a reply to message #1828837] Fri, 19 June 2020 21:50 Go to previous message
David M. Karr is currently offline David M. KarrFriend
Messages: 700
Registered: July 2009
Senior Member
I've managed to resolve this. It was just a coincidence that I saw this when I tried to open the marketplace after installing the new version. I determined that it was also failing with the old version. When I talked to one of our platform engineers, he indicated that I needed to install our company's root certs into the cacerts file. Once I did that, I was able to get to the marketplace fine.
Previous Topic:Unable to install scala in eclipse oxygen version
Next Topic:Code signature error: could not load SWT library in macOS Catalina
Goto Forum:
  


Current Time: Wed Jan 20 20:17:22 GMT 2021

Powered by FUDForum. Page generated in 0.02530 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top