Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » SCALA and BUCKMINISTER plugins are not available for latest version of eclipse?(SCALA and BUCKMINISTER plugins are not available for latest version of eclipse?)
SCALA and BUCKMINISTER plugins are not available for latest version of eclipse? [message #1828546] Thu, 11 June 2020 17:36 Go to next message
ashwini naik is currently offline ashwini naikFriend
Messages: 3
Registered: June 2020
Junior Member
Hi,

I had installed xtext, scala and buckminister plugins to eclipse INDIGO version on 2013 as per my project requirement. Now the same installation I am trying to do but I am unable to get scala and buckminister for latest version of eclipse. Scala and buckminister plugins are not available now? If yes then please can anyone suggest me the alternative plugins.
Re: SCALA and BUCKMINISTER plugins are not available for latest version of eclipse? [message #1828556 is a reply to message #1828546] Fri, 12 June 2020 02:32 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3749
Registered: July 2009
Senior Member

Buckminster's final release seems to have been in
2015. What scala plug-in are you referring to, and how are you trying to install it?


Nitin Dahyabhai
Eclipse Web Tools Platform
Re: SCALA and BUCKMINISTER plugins are not available for latest version of eclipse? [message #1828557 is a reply to message #1828556] Fri, 12 June 2020 05:47 Go to previous messageGo to next message
ashwini naik is currently offline ashwini naikFriend
Messages: 3
Registered: June 2020
Junior Member
Hi,
Thanks for your response!
I was able to download Buckminster from the archives site which you have specified. But when I extract the package I get multiple versions of it and I am not able to add it into eclipse. (I am currently using eclipse oxygen).
What I tried was ---> In eclipse go to Help->Install New Software->add->select Buckminster (from local/archive). But it doesn't work, so if you could guide me as to how I can add this archive in eclipse.

Coming to scala, I followed similar steps:
In eclipse go to Help->Install New Software->Added the link " http://download.scala-ide.org/sdk/lithium/e47/scala212/stable/site" in "Work with" dialog box. Select it and press Enter.
But I get an error stating :
HTTP Server 'Bad Gateway' : http://download.scala-ide.org/sdk/lithium/e47/scala212/stable/site/content.xml
HTTP Server 'Bad Gateway' : http://download.scala-ide.org/sdk/lithium/e47/scala212/stable/site/content.xml
HttpComponents connection error response code 502

I even tried installing scala IDE 4.7.x from EclipseMarketplace and run into a similar error:
HTTP Server 'Bad Gateway' : http://download.scala-ide.org/sdk/lithium/e47/scala212/dev/site/content.xml
HttpComponents connection error response code 502.

In 2013, I had followed the exact same steps as above and was successful in installing the same.
Do you have any insights as to why I am facing these errors now?
Re: SCALA and BUCKMINISTER plugins are not available for latest version of eclipse? [message #1828579 is a reply to message #1828557] Fri, 12 June 2020 18:26 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3749
Registered: July 2009
Senior Member

A 502 status is an internal server status error code. It'll have to be reported to whomever is running download.scala-ide.org , if possible.

Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:Plug in source code
Next Topic:switching forums
Goto Forum:
  


Current Time: Sun Jul 05 11:35:48 GMT 2020

Powered by FUDForum. Page generated in 0.02346 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top