Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Polarsys » M2Doc » The 'NewTemplate" wizard is missing(M2Doc missing wizard)
The 'NewTemplate" wizard is missing [message #1827615] Tue, 19 May 2020 11:08 Go to next message
Chris Grice is currently offline Chris GriceFriend
Messages: 6
Registered: December 2017
Junior Member
When trying to make a new template, the "select a wizard" window only shows the "new generation" not the "new template" as shown in the help files.
Where is it?

thanks
Re: The 'NewTemplate" wizard is missing [message #1827664 is a reply to message #1827615] Wed, 20 May 2020 07:41 Go to previous messageGo to next message
Yvan Lussaud is currently offline Yvan LussaudFriend
Messages: 63
Registered: July 2009
Member
The new template and project wizards were introduced in M2Doc 3.0.0. Are you using this version ? Otherwise you can refere to the documentation of your version of M2Doc either in the help contents of Eclipse (menu help/help contents) or online:

https://www.m2doc.org/

documentation menu and select your version of M2Doc.
Re: The 'NewTemplate" wizard is missing [message #1827679 is a reply to message #1827664] Wed, 20 May 2020 15:18 Go to previous messageGo to next message
Chris Grice is currently offline Chris GriceFriend
Messages: 6
Registered: December 2017
Junior Member
Is there anyway you can use the 3.0.0 M2Doc with Capella 1.2.2. We are currently limited to moving forward in Capella versions.

thks
Re: The 'NewTemplate" wizard is missing [message #1827738 is a reply to message #1827679] Fri, 22 May 2020 07:30 Go to previous message
Yvan Lussaud is currently offline Yvan LussaudFriend
Messages: 63
Registered: July 2009
Member
If you are using services form the M2Doc Capella extension, from this services class:
org.obeonetwork.capella.m2doc.aql.queries.M2DocGenServices (source)

It will not be possible because of the version range of the containing plugin.

You can either move the class or its content to one of your services class or one of your plugin to remove the dependency.

If you don't have any dependency to the M2Doc Capella extension, you can desinstall it from your Eclipse and install M2Doc 3.0.0 (or any version).
An other way of doing it is to install M2Doc 3.0.0 in a fresh Capella 1.2.2 then test your template. If you have errors about missing services, you probably have dependencies to M2Doc Capella extension.
Previous Topic:Description Tab with M2DOC
Next Topic:How to install M2Doc into Capella
Goto Forum:
  


Current Time: Wed Dec 07 23:54:45 GMT 2022

Powered by FUDForum. Page generated in 0.01820 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top