Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Installation of Eclipse IDE 2020-93 (4.15.0) inatall issues + JDK-14 support(Eclipse 2020 IDE Installation)
Installation of Eclipse IDE 2020-93 (4.15.0) inatall issues + JDK-14 support [message #1826542] Sun, 26 April 2020 22:40
Bryon Conley is currently offline Bryon ConleyFriend
Messages: 1
Registered: April 2020
Junior Member
Hello all, As a new-comer, I'm seeing potential issues during my installation that some of you may have seen before. I've done a search in the internet but did not see anything that matches what I am experiencing.

I have a Windows 64bit machine running Windows 10. I already have Java JDK-14 bundle installed fron the official Oracle Java website (Java `4).

I found the Eclipse 2020 IDE "installer" on the official Eclipse.org site and downloaded it for the Windows 64 bit (file called: Eclipse-inst-Win64.exe which appears to be a installer handler of many Eclipse IDE packages for many laguages including "eclipse IDE 2020 Java for Developers". I selected the IDE 2020 for Java Developers and hit the "jaunch" which did launch the installation process for the correct Eclipse IDE 2020 for Java Developers. The installer prompted me for two things only: (1)- Accept the license terms; and (2) asked me where to set up the eclipse-workspace which defaulted to C:\users\Bryon (which is fine). There is a checkbox that says "Check here to accept this as default and don't ask again". I did not check this one on purpose... Then I hit the Install button. All seems to go just fine and completed and it launched the Eclipse IDE 2020 for Java Developers. However, I went to my program files (apps and features) and (programs and features). The eclipse was nowhere to be found. I see the desktom shortcut and checked the properties. It installed the program and all of hits files into C:\users\Bryon\eclipse area and not the conforming programs file area? So, I do think this is odd as the installer did not prompt me for the location to install the program like all other installers for other programs have ased. I also noticed there is an eclipse-workspace present at the currect location (C:\users\Bryon) as promised. So, moving forward, I checked the internet for Java 14 support items for the Eclipse IDE 2020 and it suggested to go to the Eclipse marketplace, type in "java 14" and he first item was indeed the Java 14 su[[prt b undle for installation into my IDE. However, upon installation of this came back with the error that stated: "The following solutions are not available for: Java 14 support for Eclipse 2020-03 (4.15) Proceed anyway? I proceeded and it basically errored out with the error message stating this installation was not successful as the item was not available. I re-read the marketplace description for this bundle and it does match my installed version of Eclipse (2020-03 (4.15.0). So, a handful of question poped up in my mind:
1. Did the unorthodoxal installation location of Eclipse IDE 2020 cause this issue?
2. Why did the Eclipse installer choose such an unorthodox location?
3. Will the unorthodox installation create many issues with anything I do with Eclipse IDE 2020 i?

The marketplace installation dialog box indicated to check the error log file for details on the "Java 14 support for Exclipse IDE 2020". I went to the workspace, then metadata and opened the log file. I see the installation of Eclipse log output and a few other things (I've pasted the output of the log below). I noticed the only error involved "unreconciled version" error for xml bundle.. I did not see any error or log output in this log file for the marketplace installation attempt for "Java 14 support of Exclipse IDE 2020" though. I did see a reference by the Exclipse installer that it found my Java 14 and set it as default. Question: Does this mean I am already configured for Java 14 and don't need the marketplace installation of this bundle?

And the question remains, is the unorthodx locaation of the Eclipse program going to cause issues? If so, how do I re-install at the correct location -- the installer for Eclipse did not offer any options for this....

Thank you all for reading the lenthly description of the potential issue. Please find the log file content below:
!SESSION 2020-04-26 10:12:22.612 -----------------------------------------------
eclipse.buildId=4.15.0.I20200305-0155
java.version=14
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments: -product org.eclipse.epp.package.java.product
Command-line arguments: -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.java.product

!ENTRY org.eclipse.mylyn.bugzilla.core 4 0 2020-04-26 10:12:25.023
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.mylyn.bugzilla.core [270]
Unresolved requirement: Require-Bundle: org.apache.xmlrpc
-> Bundle-SymbolicName: org.apache.xmlrpc; bundle-version="3.0.0.v20100427-1100"
org.apache.xmlrpc [57]
Unresolved requirement: Import-Package: javax.xml.bind
Unresolved requirement: Require-Bundle: org.eclipse.mylyn.commons.xmlrpc; bundle-version="[3.8.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.mylyn.commons.xmlrpc; bundle-version="3.24.2.v20180904-2231"; singleton:="true"
org.eclipse.mylyn.commons.xmlrpc [287]
Unresolved requirement: Require-Bundle: org.apache.xmlrpc; bundle-version="[3.0.0,4.0.0)"
-> Bundle-SymbolicName: org.apache.xmlrpc; bundle-version="3.0.0.v20100427-1100"

at org.eclipse.osgi.container.Module.start(Module.java:462)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1844)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1837)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1778)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1742)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1664)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)

!ENTRY org.eclipse.mylyn.bugzilla.ui 4 0 2020-04-26 10:12:25.039
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.mylyn.bugzilla.ui [272]
Unresolved requirement: Require-Bundle: org.eclipse.mylyn.bugzilla.core; bundle-version="[3.8.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.mylyn.bugzilla.core; bundle-version="3.24.2.v20180905-0003"; singleton:="true"
org.eclipse.mylyn.bugzilla.core [270]
Unresolved requirement: Require-Bundle: org.apache.xmlrpc
-> Bundle-SymbolicName: org.apache.xmlrpc; bundle-version="3.0.0.v20100427-1100"
org.apache.xmlrpc [57]
Unresolved requirement: Import-Package: javax.xml.bind
Unresolved requirement: Require-Bundle: org.eclipse.mylyn.commons.xmlrpc; bundle-version="[3.8.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.mylyn.commons.xmlrpc; bundle-version="3.24.2.v20180904-2231"; singleton:="true"
org.eclipse.mylyn.commons.xmlrpc [287]
Unresolved requirement: Require-Bundle: org.apache.xmlrpc; bundle-version="[3.0.0,4.0.0)"
-> Bundle-SymbolicName: org.apache.xmlrpc; bundle-version="3.0.0.v20100427-1100"

at org.eclipse.osgi.container.Module.start(Module.java:462)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1844)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1837)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1778)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1742)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1664)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)

!ENTRY org.eclipse.mylyn.commons.xmlrpc 4 0 2020-04-26 10:12:25.055
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.mylyn.commons.xmlrpc [287]
Unresolved requirement: Require-Bundle: org.apache.xmlrpc; bundle-version="[3.0.0,4.0.0)"
-> Bundle-SymbolicName: org.apache.xmlrpc; bundle-version="3.0.0.v20100427-1100"
org.apache.xmlrpc [57]
Unresolved requirement: Import-Package: javax.xml.bind

at org.eclipse.osgi.container.Module.start(Module.java:462)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1844)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1837)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1778)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1742)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1664)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)

!ENTRY org.eclipse.mylyn.tasks.core 4 0 2020-04-26 10:13:59.900
!MESSAGE Unexpected error while loading repository template extensions
!SUBENTRY 1 org.eclipse.mylyn.tasks.core 4 0 2020-04-26 10:13:59.900
!MESSAGE Could not load repository template extension contributed by 'org.eclipse.mylyn.bugzilla.ide' with connectorKind 'bugzilla'

!ENTRY org.eclipse.egit.ui 2 0 2020-04-26 10:14:22.539
!MESSAGE Warning: The environment variable HOME is not set. The following directory will be used to store the Git
user global configuration and to define the default location to store repositories: 'C:\Users\Bryon'. If this is
not correct please set the HOME environment variable and restart Eclipse. Otherwise Git for Windows and
EGit might behave differently since they see different configuration options.
This warning can be switched off on the Team > Git > Confirmations and Warnings preference page.
Previous Topic:Why is it soooo difficult to SIMPLY download IDE
Next Topic:Dark theme Java syntax coloring
Goto Forum:
  


Current Time: Sun Nov 29 12:11:49 GMT 2020

Powered by FUDForum. Page generated in 0.03463 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top