Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse 2020/06 with Xcode 11.4.1 on 10.15.4, is there a requirement to have Xcode installed ?(interop issues, and what appears to be stale Xcode directories)
Eclipse 2020/06 with Xcode 11.4.1 on 10.15.4, is there a requirement to have Xcode installed ? [message #1826453] Sat, 25 April 2020 05:31 Go to next message
Sam Warner is currently offline Sam WarnerFriend
Messages: 24
Registered: April 2020
Junior Member
was playing around with getch, and trying to get libncurses.a or libcurses.a to link to resolve symbol not found issues.

While searching and searching, adding HomeBrew's version of ncurses, and finding out the Xcode had an equivalent version. I accidentally a"dded "-v" and some hours into this did a clean build only to find out that there were reams of improperly uninstalled directories from Xcode, as I am getting:

"ignoring nonexistent directory"

messages. I searched for the how InstallDir is defined, and finally began to wonder, if there's a requirement that Eclipse needs Xcode installed. I can't imagine that it does.

Anyone know?
Re: Eclipse 2020/06 with Xcode 11.4.1 on 10.15.4, is there a requirement to have Xcode installed ? [message #1826455 is a reply to message #1826453] Sat, 25 April 2020 06:14 Go to previous messageGo to next message
Sam Warner is currently offline Sam WarnerFriend
Messages: 24
Registered: April 2020
Junior Member
yes, Xcode is required.

(see image for way to configure around Xcode)
Re: Eclipse 2020/06 with Xcode 11.4.1 on 10.15.4, is there a requirement to have Xcode installed ? [message #1826459 is a reply to message #1826453] Sat, 25 April 2020 07:40 Go to previous message
Sam Warner is currently offline Sam WarnerFriend
Messages: 24
Registered: April 2020
Junior Member
Turns out there is a way to configure Eclipse to use specific c_lang compliers. By configuring one can be completely independent of Xcode Tools.

Sam
Previous Topic:Can't install Eclipse IDE 2020‑03
Next Topic:Java Eclipse/Maven, Hanging on Dependency Build for JAXB 4+ Hrs
Goto Forum:
  


Current Time: Sat Dec 05 11:30:40 GMT 2020

Powered by FUDForum. Page generated in 0.02468 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top