Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » I have question about "root elements"!
I have question about "root elements"! [message #1826086] Sat, 18 April 2020 20:17 Go to next message
Daniel Meirelles is currently offline Daniel MeirellesFriend
Messages: 1
Registered: April 2020
Junior Member
Hi guys!


I have a question about "root elements".
I'm creating my first Java application through eclipse, but I'm not getting it.
There is no "element root" for me.

What I have to do? I installed something wrong, is there anything I have to fix? How do I do?


I appreciate if you can help!
Thanks in advance!

index.php/fa/37866/0/

Re: I have question about "root elements"! [message #1826111 is a reply to message #1826086] Sun, 19 April 2020 18:19 Go to previous messageGo to next message
Stephan Herrmann is currently offline Stephan HerrmannFriend
Messages: 1828
Registered: July 2009
Senior Member
the picture shows, that the import javax... cannot be resolved. Note, that since Java 10, this is no longer part of the System library. You need to add it as a separate library to your project, perhaps after downloading, e.g., from https://openjfx.io/
Re: I have question about "root elements"! [message #1826113 is a reply to message #1826111] Sun, 19 April 2020 18:31 Go to previous messageGo to next message
Eitan Rosenberg is currently offline Eitan RosenbergFriend
Messages: 58
Registered: October 2018
Member
Hello,

I think that Daniel is using 1.8 .

odd.....

Regards.






[Updated on: Sun, 19 April 2020 18:57]

Report message to a moderator

Re: I have question about "root elements"! [message #1826119 is a reply to message #1826113] Sun, 19 April 2020 20:20 Go to previous messageGo to next message
Stephan Herrmann is currently offline Stephan HerrmannFriend
Messages: 1828
Registered: July 2009
Senior Member
Quote:
I think that Daniel is using 1.8 .


The picture shows two projects. The project where the problem occurs has a "jdk-14" System Library. Maybe that's by accident?
Re: I have question about "root elements"! [message #1826121 is a reply to message #1826119] Sun, 19 April 2020 21:23 Go to previous message
Eitan Rosenberg is currently offline Eitan RosenbergFriend
Messages: 58
Registered: October 2018
Member
Now I see thanks.
Previous Topic:Is IntelliJ faster than Eclipse?
Next Topic:Modify the Java Code Template in Wizard "New JUnit Test Case"
Goto Forum:
  


Current Time: Sun Oct 25 15:04:56 GMT 2020

Powered by FUDForum. Page generated in 0.01782 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top