Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » I have problem about No Persistence provider for EntityManager named FastMatch(This topic is about No persistence provider for EntityManager)
I have problem about No Persistence provider for EntityManager named FastMatch [message #1824177] Thu, 09 April 2020 04:08 Go to next message
Fuad Azhar Ibrahim is currently offline Fuad Azhar IbrahimFriend
Messages: 1
Registered: April 2020
Junior Member
hi all i have problem for my persistence entity manager cannot find the provider.

1. i have error when build using eclipse neon i when i run my java application i got error this
Exception in thread "main" javax persistence PersistenceException: No Persistence provider for EntityManager named FastMatch

i have try add to my persistence.xml using
<persistence-unit name="FastMatch" transaction-type="RESOURCE_LOCAL">
<provider>org.eclipse.persistence.jpa.PersistenceProvider</provider>
<class>com.dxtr.hibernate.newOrderSingleEntity</class>
<properties>
<property name="eclipselink logging level" value="INFO"/>
<property name="eclipselink logging level sql" value="FINE"/>
<property name="eclipselinkloggingparameters" value="true"/>
<property name="javaxpersistencejdbc.driver" value="com.mysql.jdbc.Driver" />
<property name="javaxpersistencejdbc.url" value="jdbc:mysql://url/tables" />
<property name="hibernate.dialect" value="org.hibernate.dialect.MySQL5Dialect" />
<property name="eclipselink.logging.level.connection" value="FINEST"/>
</properties>
</persistence-unit>
</persistence>

i also have changed using
<provider>org.hibernate.ejb.HibernatePersistence</provider> but also got same error
and i have used <provider>org.hibernate.jpa.HibernatePersistenceProvider</provider>
still same error... so how to fix my problem solution ?

i have add in my pom.xml

<dependency>
<artifactId>hibernate-core</artifactId>
<version>5.4.2.Final</version>
</dependency>
<dependency>
<artifactId>hibernate-entitymanager</artifactId>
<version>5.4.2.Final</version>
</dependency>
<dependency>
<artifactId>hibernate-jpa-2.1-api</artifactId>
<version>1.0.0.Final</version>
</dependency>

i got still error so how to fix my problem?? please help me for fix my problem
Re: I have problem about No Persistence provider for EntityManager named FastMatch [message #1824206 is a reply to message #1824177] Thu, 09 April 2020 14:32 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3707
Registered: July 2009
Senior Member

You might have better luck in the EclipseLink forum: https://www.eclipse.org/forums/index.php/f/111/. Neon is also a pretty old release at this point, you really should be on 2020-03 if you can be.

Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Thu, 09 April 2020 14:33]

Report message to a moderator

Previous Topic:Help in Setting JavaFX 11 SDK in Eclipse 2019-06
Next Topic:Fresh Install Catalina "Failed to create Java Virtual Machine"
Goto Forum:
  


Current Time: Wed May 27 22:42:11 GMT 2020

Powered by FUDForum. Page generated in 0.02736 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top