Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Error in setup with Oomph
Error in setup with Oomph [message #1823987] Mon, 06 April 2020 07:49 Go to next message
Susanne Fuchs is currently offline Susanne FuchsFriend
Messages: 27
Registered: March 2020
Junior Member
Hi,
I tried to use the Oomph Eclipse Installer following the Developer Guide https://wiki.eclipse.org/Papyrus/Papyrus_Developer_Guide/Papyrus_With_Oomph, but I keep getting the error below. Does anyone know about this problem? Thank you in advance! :)



Executing bootstrap tasks
Java(TM) SE Runtime Environment 1.8.0_241-b07
Product org.eclipse.products.epp.package.committers.latest.released
Workspace C:\Entwicklung\Workspaces\PapyrusOomph
Project org.eclipse.papyrus.master
Project org.eclipse.papyrus.dev.master
Project org.eclipse.papyrus.main.infra.master
Project org.eclipse.papyrus.main.views.master
Project org.eclipse.papyrus.main.uml.master
Project org.eclipse.papyrus.main.uml-alf.master
Project org.eclipse.papyrus.main.uml-text.master
Project org.eclipse.papyrus.main.emffacet.master
Project org.eclipse.papyrus.main.doc.master
Project org.eclipse.papyrus.main.alltests.master
Project org.eclipse.papyrus.main.misc.master
Project org.eclipse.papyrus.main.toolsmiths.master
Project org.eclipse.papyrus.dev.Oomph.master
Project org.eclipse.papyrus.dev.releng.master
Bundle org.eclipse.oomph.setup 1.16.0.v20200309-0628, build=4574, branch=1da35020a3c353b5b394468c77f8dc5906f072b7
Bundle org.eclipse.oomph.setup.core 1.16.0.v20200219-0856, build=4574, branch=1da35020a3c353b5b394468c77f8dc5906f072b7
Bundle org.eclipse.oomph.setup.installer 1.16.0.v20200309-1218, build=4574, branch=1da35020a3c353b5b394468c77f8dc5906f072b7
Bundle org.eclipse.oomph.setup.p2 1.14.0.v20200202-1112, build=4574, branch=1da35020a3c353b5b394468c77f8dc5906f072b7
Performing P2 Director (Eclipse IDE for Eclipse Committers (2020-03) + Core Development Tools + Releng Tools + Code Quality Tools + Papyrus Test Generation Framework Tools)
Offline = false
Mirrors = true
Resolving 72 requirements from 9 repositories to C:\Entwicklung\IDE\Papyrus\papyrusmaster\eclipse
Requirement org.eclipse.xtend.sdk.feature.group
Requirement org.eclipse.acceleo.feature.group
Requirement com.mountainminds.eclemma.feature.feature.group (optional)
Requirement net.sf.eclipsecs.feature.group (optional)
Requirement edu.umd.cs.findbugs.plugin.eclipse.feature.group (optional)
Requirement org.eclipse.oomph.projectconfig.feature.group
Requirement org.eclipse.oomph.projectcopy.feature.group
Requirement org.eclipse.oomph.workingsets.feature.group
Requirement org.eclipse.oomph.version.feature.group
Requirement org.sonatype.tycho.m2e.feature.feature.group
Requirement org.eclipse.emf.sdk.feature.group
Requirement org.eclipse.gmf.runtime.notation.sdk.feature.group
Requirement org.eclipse.gmf.runtime.sdk.feature.group
Requirement org.eclipse.gmf.sdk.feature.group
Requirement org.eclipse.uml2.sdk.feature.group
Requirement org.eclipse.papyrus.sdk.feature.feature.group
Requirement org.eclipse.pde.api.tools.ee.feature.feature.group
Requirement org.eclipse.mylyn.ide_feature.feature.group
Requirement org.eclipse.mylyn.java_feature.feature.group
Requirement org.eclipse.mylyn.pde_feature.feature.group
Requirement org.eclipse.mylyn.team_feature.feature.group
Requirement org.eclipse.mylyn.gerrit.feature.feature.group
Requirement org.eclipse.mylyn_feature.feature.group
Requirement org.eclipse.mylyn.bugzilla_feature.feature.group
Requirement org.eclipse.mylyn.git.feature.group
Requirement org.eclipse.mylyn.hudson.feature.group
Requirement org.eclipse.mylyn.wikitext_feature.feature.group
Requirement org.eclipse.egit.feature.group
Requirement org.eclipse.egit.mylyn.feature.group
Requirement org.eclipse.m2e.feature.feature.group
Requirement epp.package.committers [4.15.0,5.0.0)
Requirement org.eclipse.platform.feature.group [4.15.0,5.0.0)
Requirement org.eclipse.rcp.feature.group [4.15.0,5.0.0)
Requirement org.eclipse.buildship.feature.group
Requirement org.eclipse.e4.core.tools.feature.feature.group
Requirement org.eclipse.eclemma.feature.feature.group
Requirement org.eclipse.egit.gitflow.feature.feature.group
Requirement org.eclipse.epp.mpc.feature.group
Requirement org.eclipse.jdt.feature.group
Requirement org.eclipse.jdt.source.feature.group
Requirement org.eclipse.jgit.http.apache.feature.group
Requirement org.eclipse.mylyn.builds.feature.group
Requirement org.eclipse.mylyn.commons.feature.group
Requirement org.eclipse.mylyn.commons.identity.feature.group
Requirement org.eclipse.mylyn.commons.notifications.feature.group
Requirement org.eclipse.mylyn.commons.repositories.feature.group
Requirement org.eclipse.mylyn.commons.repositories.http.feature.group
Requirement org.eclipse.mylyn.discovery.feature.group
Requirement org.eclipse.mylyn.gerrit.dashboard.feature.feature.group
Requirement org.eclipse.mylyn.monitor.feature.group
Requirement org.eclipse.mylyn.reviews.feature.feature.group
Requirement org.eclipse.mylyn.versions.feature.group
Requirement org.eclipse.pde.feature.group
Requirement org.eclipse.pde.source.feature.group
Requirement org.eclipse.platform.source.feature.group
Requirement org.eclipse.rcp.source.feature.group
Requirement org.eclipse.wildwebdeveloper.feature.feature.group
Requirement org.eclipse.oomph.setup.feature.group
Requirement org.eclipse.oomph.targlets.feature.group
Requirement org.eclipse.oomph.setup.targlets.feature.group
Requirement org.eclipse.oomph.setup.pde.feature.group
Requirement org.eclipse.oomph.setup.git.feature.group
Requirement org.eclipse.oomph.setup.mylyn.feature.group
Requirement org.eclipse.mylyn.tasks.core
Requirement org.eclipse.mylyn.tasks.ui
Requirement org.eclipse.oomph.setup.projects.feature.group
Requirement org.eclipse.oomph.setup.workingsets.feature.group
Requirement org.eclipse.m2m.qvt.oml.sdk.feature.group
Requirement org.eclipse.gmf.tooling.codegen.xtend2.feature.group
Requirement org.eclipse.upr.utp (optional)
Requirement org.eclipse.upr.utp.papyrus (optional)
Requirement org.eclipse.oomph.setup.jdt.feature.group
Repository http://update.eclemma.org/
Repository http://eclipse-cs.sourceforge.net/update/
Repository http://findbugs.cs.umd.edu/eclipse/
Repository http://repo1.maven.org/maven2/.m2e/connectors/m2eclipse-tycho/0.9.0/N/LATEST/
Repository http://download.eclipse.org/modeling/gmp/gmf-tooling/updates/releases/
Repository http://download.eclipse.org/technology/epp/packages/2020-03
Repository http://download.eclipse.org/releases/2020-03/202003181000
Repository http://download.eclipse.org/oomph/updates/milestone/latest
Repository http://download.eclipse.org/upr/nightly/standardized/update/
Adding repository http://update.eclemma.org/
Adding repository http://eclipse-cs.sourceforge.net/update/
Adding repository http://download.eclipse.org/releases/2020-03/202003181000
Adding repository http://download.eclipse.org/technology/epp/packages/2020-03
Adding repository http://download.eclipse.org/oomph/updates/milestone/latest
Adding repository http://repo1.maven.org/maven2/.m2e/connectors/m2eclipse-tycho/0.9.0/N/LATEST/
Adding repository http://download.eclipse.org/modeling/gmp/gmf-tooling/updates/releases/
ERROR: org.eclipse.equinox.p2.transport.ecf code=1002 HTTP Server 'Not Implemented': http://repo1.maven.org/maven2/.m2e/connectors/m2eclipse-tycho/0.9.0/N/LATEST/content.xml
ERROR: org.eclipse.ecf.identity code=0 HttpComponents connection error response code 501.
at org.eclipse.ecf.provider.filetransfer.httpclient45.HttpClientFileSystemBrowser.runRequest(HttpClientFileSystemBrowser.java:276)
at org.eclipse.ecf.provider.filetransfer.browse.AbstractFileSystemBrowser$DirectoryJob.run(AbstractFileSystemBrowser.java:69)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)
Re: Error in setup with Oomph [message #1823989 is a reply to message #1823987] Mon, 06 April 2020 08:44 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6984
Registered: July 2009
Senior Member
Hi

The error follows
Adding repository http://download.eclipse.org/modeling/gmp/gmf-tooling/updates/releases/

Examining its contents, it looks really smelly.
https://bugs.eclipse.org/bugs/show_bug.cgi?id=561805 raised

Regards

Ed Willink
Re: Error in setup with Oomph [message #1824086 is a reply to message #1823989] Tue, 07 April 2020 16:19 Go to previous messageGo to next message
Susanne Fuchs is currently offline Susanne FuchsFriend
Messages: 27
Registered: March 2020
Junior Member
Thank you Ed!
Re: Error in setup with Oomph [message #1824334 is a reply to message #1824086] Tue, 14 April 2020 06:21 Go to previous messageGo to next message
Susanne Fuchs is currently offline Susanne FuchsFriend
Messages: 27
Registered: March 2020
Junior Member
Hi Ed,

I saw that the bug was closed invalid. Did you figure out what the problem was?

Regards

Susanne
Re: Error in setup with Oomph [message #1824456 is a reply to message #1823989] Wed, 15 April 2020 14:42 Go to previous messageGo to next message
Susanne Fuchs is currently offline Susanne FuchsFriend
Messages: 27
Registered: March 2020
Junior Member
Hi,

I think the error is the same as here
https://github.com/eclipse/kura/issues/2632

it should be https instead of http in
http://repo1.maven.org/maven2/.m2e/connectors/m2eclipse-tycho/0.9.0/N/LATEST/

I'm sorry, I'm still new, could someone who knows how to do this fix it?
Re: Error in setup with Oomph [message #1824490 is a reply to message #1824456] Thu, 16 April 2020 07:55 Go to previous message
Susanne Fuchs is currently offline Susanne FuchsFriend
Messages: 27
Registered: March 2020
Junior Member
I raised https://bugs.eclipse.org/bugs/show_bug.cgi?id=562196
hope I did it correctly
Previous Topic:R-E-A-L (Rapid Engineering Architecture Linked)
Next Topic:Best version of Eclipse and Papyrus SysML
Goto Forum:
  


Current Time: Sat Jan 16 11:15:00 GMT 2021

Powered by FUDForum. Page generated in 0.01992 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top